2 Replies Latest reply on Apr 28, 2014 11:11 AM by StigidyMarley

    HD 4000 v10.18.10.3412 Windows 8.1 Problem.

    StigidyMarley

      I have just updated my HD 4000 graphics card drivers to their latest build as I was having persistent crashes when trying to play The Elder Scrolls Online and I am now receiving Direct3d and other errors whenever I try to launch any graphical application.

       

      Errors include:

       

      Could not load direct3d

      Error initializing D3D9 device: Shader Model 3.0 is required.

      Video Card Not Supported. Unable to initialize render device

      Failed to initialize renderer!

       

      I have tried reinstalling the new driver but that hasn't fixed the problem. I have also tried installing a previous version but it just ends up installing the latest patch. For some reason the rollback function isn't available and my recent restore points aren't applying properly when I try those.

       

      My laptop is a Lenovo Ideapad z500 and also has an Nvidia GeForce GT 645M - if I disable the Intel chip my applications will launch without errors but run poorly so I figure the problem must be related to the Intel chip or drivers. It was working perfectly on other applications prior to the update.

       

      Please find attached a copy of my DxDiag report if that helps.

       

      Ideally a fix for the latest patch would be perfect, allowing me run to run TESO without the crashes. Although I'd be happy just to get to an older version of the driver which isn't problematic for me (if there is any way of making this possible?). Any help is greatly appreciated!


      Thank you.


      Joe

        • 1. Re: HD 4000 v10.18.10.3412 Windows 8.1 Problem.
          kevin_intel

          Hello StigidyMarley,

          I am sorry you are having problems but let me help you.

           

          Based on the information you have provided I noticed you install an older driver version (not the latest) so please uninstall the current driver and install this driver:

          https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3712&DwnldID=23714

           

          If you get any problem during the installation, try the steps mentioned at the following link:

           

          https://communities.intel.com/docs/DOC-22542

          • 2. Re: HD 4000 v10.18.10.3412 Windows 8.1 Problem.
            StigidyMarley

            Hi Kevin,

             

            Thanks for the reply. I did initially install the most recent driver version (file win64_153318.exe) this was when my computer refused to launch any graphical applications with the above errors. I then tried to delete and install the previous version (this didn't appear to work, as in device manager it was still showing the latest driver) but I guess it must have worked, although I still continued to get the problems.

             

            I have (somehow) temporarily fixed the issue. I actually deleted my Nvidia driver and my 4000 driver, rebooted my computer, after the restart I had no drivers installed. Somehow my computer took it upon itself to re-install drivers for both the devices and now my applications seem to be running okay. I'm a bit concerned about deleting and updating to the most recent driver (when it was upon doing so that I started experiencing problems). I think I'll stick with what it has installed (V10.18.10.3412) until a newer driver is released.

             

            But many thanks for your assistance.

             

            Joe