4 Replies Latest reply on Sep 5, 2017 2:34 PM by Intel Corporation

    HD 4000 Poor Textures

    Jetway

      While my descrete gpu is being RMA'd I'm using hd 4000 of my i5 3570k. The problem is when the settings in 3d section are set to 'balanced' in the title I play (Two Worlds 1) the in-game distant textures look too blurry. If set to 'quality' everyting's fine BUT! in 10.18.10 series of drivers those settings don't work and the picture is the same no matter if I set performance, balanced or quality. In 9.17.10 series with old CP it works fine but those drivers are a good bit worse in terms of FPS. Also anisotropic filtering set manually doesn't work in both versions... well hack with that... but why on earth are those performance-quality presets are ignored by the driver? I don't want to downgrade to old drivers 'cause I loose in performance (no in-game possibility to set any kind of texture filter). Re-checked the issue in other 3d apps and it is just the same - no reaction to quality preset or manual aniso.

        • 1. Re: HD 4000 Poor Textures
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          : Thank you very much for joining the Intel® Graphics communities. We are sorry to hear there is a problem with the PC.
           
          In regard to your question about the quality preset, it will depend if the proper driver for your system is installed, otherwise it might not work as it should. In order to try to fix this problem we can try to install graphics driver version 4653, which is the latest for the Intel® HD Graphics 4000 controller:
          https://downloadcenter.intel.com/download/26813/Intel-Graphics-Driver-for-Windows-15-33-?product=81499
           
          To better assist you, we just need to verify a few details:
          What is the model of the motherboard?
          If this is a laptop, what is the model of the laptop?
          Which Windows version are you using?
           
          Any further questions, please let me know.
           
          Regards,
          Alberto R
           

          • 2. Re: HD 4000 Poor Textures
            Jetway

            4653 already installed. Dual boot - win7sp1x64, win10prox64 anniversary update (issue on both). Desktop. Mobo Asus p8z77 v-lx (latest bios) with i5 3570k. Actually tried different versions of 9.18.10 and 10.18.10 (new control panel) nad the issue is present. QULITY PRESET NOT WORKING. Any 9.17.10 driver with old control panel is OK - that is - all the three presets are visually different according to their names, while in new drivers no changes. Anisotropic filtering set manually doesn't work in all versions, but as I understand it never worked. Still anything to be modified in latest drivers to activate qality level? I already monitored registry and driver files addressed by the apps and the feeling is that reg settings set by the control panel are ignored and something has to be changed in dlls, maybe, LOD or filter quality...

            • 3. Re: HD 4000 Poor Textures
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Thank you very much for letting us know those details. We will start a research on this matter in order to try to find a possible solution. For us to be able to do that, please provide the information requested on the link below for both, Windows® 7 and 10:
              https://communities.intel.com/thread/77761

              Any questions, please let me know.

              Regards,
              Alberto R

              • 4. Re: HD 4000 Poor Textures
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                I just wanted to check if you saw the information we requested previously and if you need further assistance on this matter?
                 
                Any questions, please let me know.
                 
                Regards,
                Alberto R