1 Reply Latest reply on Mar 17, 2016 1:25 PM by allan_intel

    iaStorA - hard drive disconnecting


      I wish to report a problem I have encountered whereby a hard drive would regularly appear to disconnect (sometimes for 30-60 seconds or so and sometimes until reboot) whilst using both the (manufacturers recommended) Intel SATA RAID/AHCI driver and the more recent updated driver.


      The motherboard is a Gigabyte GA-H110M-S2HP and the hard drive a Samsung 640GB HD642JJ (this is a secondary drive, the OS is on a Samsung SSD).

      Each time the problem occurred I would need to wait 30-60 seconds to access the drive again (or sometimes reboot the system) and the SMART UMDA CRC error count would increment by one or two.

      At first I assumed a hardware problem and changed SATA data cables, power cables, motherboard input locations etc. I even tried a different firmware for the drive. Then I stumbled across problems with the intel driver and tried switching to the standard microsoft AHCI SATA controller which solved the issue.

      Unfortunately, benchmarks indicate I have suffered a slight performance drop with the SSD and would prefer to use the recommended intel driver if this issue did not occur.

      I hope someone finds this information useful.