7 Replies Latest reply on Mar 15, 2016 12:44 PM by mikec_intel

    NUC5CPYH going around in circles on opensuse 13.2 64-bit install

    World_Leader

      I have decades of experience building and installing and fixing systems.

       

      This NUC5CPYH has me stymied after dozens of go-arounds.

       

      Installed: Hyper-X 8gb SO-DIMM, SanDisk 120GB SSD, sees it fine.

       

      Try to install from USB3.0 stick (used before on other systems) or DVD (USB optical), same exact bad results:

       

      I get the SuSE install splash screen, what do you want to do, choose Install, the booting starts with the usual linux messages,

      gets to 'starting udev...' and halts so hard I have to power-cycle the NUC, the monitor loses any connection (green->yellow, VGA),

      keyboard also seems disconnected. It sometimes will only power down if I hold the power button for several seconds, sometimes
      I just pull the power plug (which always works of course.)

       

      I set the BIOS so it stops to ask me what to do on power-up, ESC to boot or F2 to set-up. F2 never works, just spins with

      blank screen. Fast boot is not enabled. So to get to visual BIOS I have to power off then hold down power button until it

      goes from blue to reddish so I get a menu and then F2 works. Not the biggest problem but slows down experiments and

      feels...wrong?

       

      Also, went through iterations of UEFI, Legacy, both enabled for USB boot. Without changing anything further just power-cycling

      and going into F10 boot menu it seems to sometimes offer me UEFI USB boot, sometimes not UEFI USB boot. Just unpredictable.

      Only the non-UEFI goes to install splash screen so often have to try (power cycle, hold down until red, menu, F10).

       

      ALSO, the BIOS firmware says 0043. I tried updating (USB) in various ways using F7 boot menu or via the fancy (very nice btw)

      visual BIOS menus, find the file (PY0048.BIO), say ok, and nothing really happens. The screen goes blank and it seems to reboot

      or power-cycle and still version 43. I thought a BIOS update might help with the above problems.

       

      But why does it start booting the installation, expected splash and menus, and then seems to halt hard as it's starting their installation

      linux?

       

      I'm also a little disturbed at the unpredictability of this BIOS. Hitting F2 on BIOS boot screen doesn't work just get a blank screen

      and nothing (again fast boot not enabled), BIOS won't update, boot menu changes options between tries even tho absolutely nothing

      has been changed, etc. Googling around it seems some of these problems are common among owners it's not just me.

       

      I had such high hopes for this thing but now after 2 days going around in circles I'm having my doubts.

       

      Maybe I'm missing just one little thing so I'm asking here. Thanks.

        • 1. Re: NUC5CPYH going around in circles on opensuse 13.2 64-bit install
          World_Leader

          On the approx 53rd go-round in approx 53 hours it decided to let me update the BIOS from 43 to 48, got into the Visual BIOS and confirmed

          this so something went right...let's see about the other issues...

          • 2. Re: NUC5CPYH going around in circles on opensuse 13.2 64-bit install
            World_Leader

            No change I can see after going from 0043 to 0048. SuSE install still halts after saying "starting udev...', screen

            goes black, monitor indicates no connection, then after a few minutes the NUC seems to reboot itself and goes

            back to Auto-Start (as I set it), press ESC for normal boot, <F2> for setup and pressing <F2> never ever works,

            have to shut off and then do the long press on the power button to get into Visual BIOS.

             

            I suppose you want to say this is an opensuse problem. Not entirely unreasonable but one wonders about

            the claimed compatibility of all this. What else is going to be "opensuse's" fault?

            • 3. Re: NUC5CPYH going around in circles on opensuse 13.2 64-bit install
              World_Leader

              The failure was with opensuse 13.2 install both USB 3.0 thumb drive and DVD in a Samsung USB optical drive.

               

              On a whim I stuck an opensuse 13.1 install disk into the optical drive and it seems to be installing tho it can't

              figure out graphics for X11 so I'm doing this in text mode which is "ok", a little clumsy but the install is installing

              (network set up, disk partitioned, etc.)

               

              It's conceivable that there's some sort of corruption or incompatibility on that 13.2 distro since I burned

              the DVD and thumb drive from the same downloaded disk file.

               

              Downloading newer opensuse Leap 42.1 ISO to maybe try all over again.

               

              Still not happy with how awkward / unpredictable the BIOS is but I think I've figured out enough magic

              to live with it. It needs some serious QA by Intel. But the Visual BIOS is lovely.

              • 4. Re: NUC5CPYH going around in circles on opensuse 13.2 64-bit install
                World_Leader

                More joy. Opensuse boots from the SSD but screen is unreadable, just blocky white stripes etc. Hitting ALT-F2 to go to a text prompt gets something vaguely looking like it's trying to give a text prompt but is just blocky gibberish.

                 

                Another BIOS / Visual BIOS bug

                 

                I tried to increase the graphics memory under Video to the max as on initial install opensuse complained about not enough graphics memory for X11. And the aperature, both to the max (I think that's 512MB and 1024MB respectively.)

                 

                Then hit F10 to save, choose YES, and it just returns to that Visual BIOS video screen with no indication why it just keeps returning to visual BIOS rather than saving and exiting.

                 

                Maybe it doesn't like my settings but an error message would be nice, not just ignoring my attempts to save.

                • 5. Re: NUC5CPYH going around in circles on opensuse 13.2 64-bit install
                  World_Leader

                  Perhaps I'm shouting down a hole here but success.

                   

                  The latest (today is 2016-03-15) opensuse, openSUSE-Leap-42.1-DVD-x86_64.iso (downloadable from opensuse.org, click Leap) worked from a DVD. It would probably work from a thumb drive but I tried the DVD first. My guess is that this newest release is reasonably NUC aware (or components thereof, Intel HD graphics, etc.)

                   

                  By "worked" I mean the installer booted into graphics (X11) mode as expected, nothing surprising during the initial configuration and install, and it resulted in a usable system with X11 working on the console (none of the console stuff worked in previous tries.) It comes up in a fairly low-resolution setting (480x600 I think it was) but that can be fixed by just using the KDE tool for display configuration. I set it to 1024x768 which is all this old monitor will deliver and now it's a thing of beauty.

                   

                  And the SuSE OS itself seems to be working fine, networking is working, haven't done much with it in the 45 mins it's been up and running. Let's see how stable it is, I need reasonable stability.

                   

                  I can probably live with the BIOS misbehavior since with luck one doesn't have to interact with the BIOS often but I need it to boot into the OS without hesitation, I think I can figure that out, set default boot device, no auto-whateveritis.

                   

                  Perhaps this will be helpful to someone else.

                  • 6. Re: NUC5CPYH going around in circles on opensuse 13.2 64-bit install
                    World_Leader

                    Some random unsolicited advice on installing:

                     

                    I create one regular partition, /dev/sda1, which is 2GB for /boot, the default is a little small and if you run out of space on that partition such as updating the kernel you are in for a world of pain and can end up with an unbootable system if an update fails due to lack of disk space.

                     

                    The rest I assign to a logical volume which unfortunately involves getting more personal with the Expert Partitioner than some might be accustomed to. Under that I create several logical volumes (under one volume group, system, but whatever you like), /root, /usr, /tmp, /var, /home, swap (can be a logical volume) not using up all the LVM space as any of those logical volumes can then later be expanded either via Yast or lvresize directly.

                     

                    Of course there are many ways to do all that depending on your needs but since I've been configuring linux systems for many years perhaps some food for thought.

                     

                    Also, I still use EXT4 on all partitions for no deep, deep reason other than the toolchains for dealing with ext4 remains more mature. But, again, YMMV.

                    • 7. Re: NUC5CPYH going around in circles on opensuse 13.2 64-bit install
                      mikec_intel

                      Hi World_Leader,

                       

                      Intel does not test and validate Intel® NUC on Linux; however we know that a lot of NUC owners are using it successfully on many different Linux distros.

                      Intel suggests you check your Linux distro's website and forums at https://www.opensuse.org/ for peer assistance with this issue.

                       

                      Intel has tested and verified the behavior of the following operating systems on NUCs

                      Supported Operating Systems for Intel® NUC Products

                       

                      I recommend you to follow the steps below in order to update the BIOS.

                      Intel® NUC BIOS Recovery Update Instructions

                       

                      Regards,
                      Mike C