10 Replies Latest reply on Oct 3, 2016 11:26 PM by aroberts394

    Mraa Libraray Aio Issue

    taha82

      Hi,

          I am trying to read some sensors data in node.js by using mraa. I am able to read values from PIN1 by using the bellow code

       

      var analogPin1 = new mraa.Aio(1); //setup access analog inpuput pin 0

      var analogValue = analogPin1.read(); //read the value of the analog pin successfully

       

      but  new mraa.Aio(0), new mraa.Aio(2), new mraa.Aio(3) are giving me this error "Error: Invalid AIO pin specified - do you have an ADC?"

       

      var analogPin3 = new mraa.Aio(0); //Error

      var analogValue = analogPin3.read();

              

      I also tried to get the value through galileo-io but it is giving me same error

       

      board.analogRead("A0", function(data) {

      console.log('data', data);

      });

       

      I checked the value through cat /sys/bus/iio/devices/iio:device0/in_voltage0_raw and I am successfully getting the result back, so it is most likely mraa issue

       

      I have the latest linux IoTKit image on the SD card and mraa library is updated 0.9.5

       

      I ffound there are other people facing the same issue as me

       

      std::invalid_argument

      Initializing Aio instance fails on Galileo Gen 2 (aio: unable to setup multiplexers for pin) · Issue #117 · intel-iot-de…

      Checking Analog 4 input pin in Linux

      Hi,I am getting an error "Error: Invalid AIO pin specified - do you have an ADC? ", while working with Intel EDISON board with Intel Iot XDK IDE,can any one help me in solving this issue?

       

      Does anyone Know what could be the reason for it?