12 Replies Latest reply on Mar 15, 2016 4:51 AM by sady92

    Tried to Update BIOS, now Intel NUC is a Brick!

    sady92

      Hi everyone,

       

      Since i purchased intel nuc, i've had only issues, i have a NUC5i5RHY, and i last night i tried to update the bios from 3.5.0 to 3.5.4, now, to do this i used the F7 option, and formated my USB to FAT (though mac os x disk util).

       

      It went okay from booting to BIOS, pressing F7, and picking the file to update, after i chose the file, the screen turned black. Now i cant seem to enter in any BIOS whatsoever.

       

      I tried recover, maintenance mode, and those other ********. But nothing is getting displayed on the screen.

       

      On the power button there is no blinkings, and i tried Reseting CROM (or how it is called). But when i keep the Power button for longer than 3 seconds, it simply turns off, no beeps, nothing.

       

      I am sure i dont have problems with RAM or HDD, since it was working fine before the update.

       

      I tried removing the yellow plastic thing to send the BIOS into maintainance mode, or anything like that, but didnt work.

       

      Any help is highly appreciated.

       

      Model: NUC5i5RHY

      RAM: 2 x 8GB

      HDD: 32GB SSD.

      HDMI Mini to HDMI cable

      Also tried MiniDisplay (didnt work).

       

      Regards

      Sadi