1 2 3 Previous Next 128 Replies Latest reply on Sep 7, 2016 11:52 AM by Nikola87

    Graphics corruption in Fallout 4 since 1.3 patch

    quake

      Since Fallout 4's 1.3(.47) patch, I (and many, many others) have been experiencing texture issues that make the game unplayable. I have an Iris 5100, but the problem seems to be universal across all Intel GPUs, regardless of hardware.

      XztZJmb.jpg

      More images are in this gallery here. Basically, the textures stretch and warp, almost always obscuring your view and looking like a mess. It's interesting to note that this does not happen to player/character models, although it's difficult to discern what these textures originally were to begin with. Updating to the latest beta driver does not fix it (although I'd never seen the bright red texture glitch in the gallery before it, so... there's that).

       

      I originally believed this to be a problem combining Apple hardware (I'm using a late-2013 rMBP) with the Intel GPU, which is not officially supported by Bethesda (the game's publisher), but since then I've encountered many people across the internet on other hardware who are encountering the same issue. In fact, there seems to be something about the 1.3 update that screwed up textures for a lot of people with integrated graphics, including those with AMD.

       

      Someone will probably inevitably say that Apple has requested that all issues with their products should be directed through their support, but quite frankly, this doesn't seem like an Apple problem (and the Apple person I talked to agreed with me, saying they can only work to apply fixes within OS X). The game was made by Bethesda, runs solely in a Windows environment, and the common denominator seems to be the Intel GPU. Bethesda is aware of the problem, but are under no obligation to support users of hardware they never offered support to. While I don't know much about driver programming, I feel like this is an issue that will most likely be solved by you at Intel if it is solved at all. You also are under no obligation to solve the problem, and if you can't, no hard feelings (really). This GPU has felt like "the little graphics card that could", given the amount I've put it through, and this is the first game I've encountered that is entirely unplayable because of it.

       

      I unknowingly solved the crashing problems already known by installing ENBoost, a utility that is known to boost performance -- for some reason it completely stops the crashing other Intel users have been experiencing. The game runs just fine on versions 1.1 (release) and 1.2, and I'm continuing to play the game thanks to downgrade patches, but any future content will be unavailable unless the issue is fixed.

       

      I've attached the Intel SSU diagnostics, DxDiag, and DispDiag for reference, but a summary of my system specs is as follows: Macbook Pro Retina, Late-2013, Intel Core i5-4258U CPU @ 2.40GHz, Intel Iris Graphics 5100, 8GB RAM, Windows 10 Pro, graphics driver version 20.19.15.4380 (which I think is the beta driver? don't know what else it would be, since I turned auto-updates off and haven't installed another since). I was previously on the last stable release, which I found to run significantly better than the Apple-provided one that installs during Boot Camp.

       

      Sorry for the info dump, I'm just really interested in helping to figure out a solution if possible. I know this has been posted about a few times as well, hope this isn't a problem as I didn't want to hijack any more threads. If there's anything else I can do to help, please let me know -- I'm hoping I'll be able to get some users not on Apple hardware to post their information as well. Thank you in advance!

        1 2 3 Previous Next