6 Replies Latest reply on May 30, 2016 11:10 AM by Intel Corporation

    6i3SYK freezes and reboots on certain tasks in Ubuntu 15.10

    simov

      Hey,

       

      I know Linux isn't officially supported but still here is my configuration and issue:

       

      - [NUC6i3SYK](http://ark.intel.com/products/89186/Intel-NUC-Kit-NUC6i3SYK)

      I have it for exactly 3 weeks now .. after reading all these issues I'm starting to feel lucky I guess.

      See the attached image for the Serial Number.

       

      - [BIOS Version 0024 - SYSKLi35.86A.0024.2015.1027.2142](https://downloadmirror.intel.com/25822/eng/SY_0036_ReleaseNotes.pdf)

      The stock BIOS 0.24, all defaults.

       

      - [KVR21S15S8/4](http://www.kingston.com/dataSheets/KVR21S15S8_4.pdf)

      Kingston Value RAM 2x4GB DDR4 2133MHz, nothing fancy or otherwise overclocked.

       

      - [Kingston M.2 2280 120GB](http://www.kingston.com/en/ssd/s#sm2280s3g2)

      Kingston 120GB M.2 22x80, SN: sm2280s3/120g

       

      - Currently attached USB devices:

        - [Hama](https://www.hama.com/00049218/hama-bluetooth-usb-adapter-version-40-c2-+-edr?bySearch=49218)

        Bluetooth Nano Adapter, SN: 49218, plugged into the front USB3 port

        I had issues with Ubuntu and the Intel's 8260 Wifi/Bluetooth, more on that [here](http://askubuntu.com/questions/736191/ubuntu-gnome-15-10-intel-8260-wifi-wifi-bluetooth-issues/737302#737302)

        - USB3 Extension Cable on the rear USB3 port and then a cheap USB2 Hub, my keyboard is plugged in there

       

      - My LAN cable is plugged in. I occasionally am switching to it through the Wicd network manager in Ubuntu, in cases when the Wifi becomes too unstable. Otherwise I have been using it through the Wifi adapter most of the time. Note that I'm not using the internal adapter for Bluetooth.

       

      - I'm using HDMI to DVI cable with an old Samsung 1680x1050 60Hz monitor, but I'm planning on using the DP port with a 2K monitor soon.

       

      - [Ubuntu Gnome 15.10](https://wiki.ubuntu.com/UbuntuGNOME)

        Regular clean install from a USB stick, all partitions were automatically created by the installer.

        Kernel version: 4.2.0-30-generic

        GNOME Shell 3.16.4

       

       

      I'm kind of scared to say it, but it works pretty stable so far (exactly 3 weeks at the time of writing). Despite the bluetooth/wifi problems, that were kind of solved (see the link above).

       

      I also disabled wake on USB in Ubuntu, and I'm waking it up using the Power Button.

       

      ---

       

      What I've started experiencing this week after I finally started using the NUC for work is that the entire PC freezes for 10 seconds and restarts itself after that.

       

      I narrowed down the issue to the Integrated Graphics unit. The issue is easily reproducible using this [WebGL demo](http://myshards.com)

       

      I can easily get the NUC working for days, but if I'm doing certain GPU related tasks I'm starting experiencing some artifacts - a line appears for a second or the screen goes blank for a second.

       

      I'm not watching WebGL demos all day long, but sometimes I do have around 5 instances of Sublime Text 3 running, and although it's a pretty light weight text editor it's actually a GPU intensive application. It uses heavy 2D rendering for its UI goodies. So having that with a bunch of open tabs in Chrome can lead to the freeze and restart issue at some point in time. It's not overheating related, the NUC is barely warmed up at the top.

       

      So my best bet is a GPU driver issue, since there isn't official one for Linux. If anyone can test this demo http://myshards.com on a similar NUC with Windows that would be great.

       

       

       

      /cc JohanAR2

        • 1. Re: 6i3SYK freezes and reboots on certain tasks in Ubuntu 15.10
          ganboing

          I have a NUC6i3SYK which runs Ubuntu 15.10 as well. The demo runs fine on my machine. Please update the graphic driver from 01.org | Intel Open Source Technology Center if you haven't done so. Also update the bios to the newest version.

          • 2. Re: 6i3SYK freezes and reboots on certain tasks in Ubuntu 15.10
            simov

            Thanks ganboing installing the driver fixed the issue for me. I knew about it, but it seems that they released the latest version on 16 Feb, and I was installing Ubuntu on 11 Feb so that's how I missed it.

             

            I'm hesitant about installing the latest BIOS though, because I'm not experiencing any other major issues at this point.

            • 3. Re: 6i3SYK freezes and reboots on certain tasks in Ubuntu 15.10
              jw2dotorg

              I hope you continue to have success, but I've not been so lucky (I have the i5 model).   I installed Ubuntu 15.10 from a live usb stick to a M2 SSD, and everything worked flawlessly for a few weeks.   I was running everything out of the box from Ubuntu 15.10 -- the stock 4.2 kernel, no special video drivers, and everything was great.   Ethernet worked.  Wifi worked.  All USB worked.  I had it hooked to an HDMI monitor and used audio from the monitor.  No issues.  I was even running the Android SDK with various Android emulators playing games, with no problems.   I also fired up a KVM virtual machine to run a Plex server, and it ran great for a week or more.


              Then, I noticed it went off the network, so I saw that it had rebooted and was back to a Ubuntu login screen.   As soon as I logged in, and the desktop loaded, it froze for 5 seconds and rebooted.   So, we'e back to the login screen:  Login.  Freeze.  Reboot.   This pattern is 100% reproducible.

               

              Since I was on firmware 0028, I thought I'd check out 0033, only to find out it was pulled.  So, I waited for 0036, installed it, but still have the same problem.  I tried upgraded to the 4.3 mainline kernel, tried the 1.4.0 Intel video drivers.   No matter what I do, it's the same result.  I also tried to run the original live USB stick of Ubuntu, and it crashes immediately after login, which makes me agree that there's something GPU related going on there.    If I boot Ubuntu, and don't login at the console, but instead just SSH in remotely, it's stable for a while.  But, once I fire up the Plex virtual machine, it reboots on it's own again within a matter of minutes.

               

              The other odd thing is sometimes the Visual BIOS will state that the Core CPU Temp is 250.00 degrees.   If I reboot it and go back into the BIOS 5 seconds later, it's back to 48.0.    The sensors or something are just too flaky to waste any more time on it.  I contacted Intel for a replacement.   I'm not convinced that this unit is ever going to be stable.  Oh, and I'm using the Kingston HyperX memory that is supposed to be the 'most compatible'.

              • 4. Re: 6i3SYK freezes and reboots on certain tasks in Ubuntu 15.10
                simov

                Thanks for the feedback jw2dotorg.

                 

                I'm not trying to be smart in here, but isn't the HyperX memory supposed to be the one with overclocked timings, hence the one with worse thermal profile. I know it was suggested in other threads here, but that was only compared to other brands that doesn't work at all. I read in some thread in this forum that someone suggests that if the memory is too hot it may damage the CPU on the other side of the board over time. Don't get me wrong, if I had the I5 I would most definitely go for the HyperX as well, and if overheating is the problem that would be truly a shame, but it's a clue nevertheless.

                 

                BTW Sprint and Summer are coming here so I'll have my shot at frying it up (if that's the case).

                 

                Another thing that I forgot to mention in my first post (although it might be completely unrelated) is that it's always a good idea to put your mini PCs behind a good Surge Protector. I have this one [APC P1T-GR](http://www.apc.com/shop/bg/en/products/APC-Essential-SurgeArrest-1-outlet-with-Phone-Protection-230V-Germany/P-P1T-GR). I have another mini PC that I assembled myself, so the case that I have is with some pretty weak PSU with external brick. One night, before I had a Surge Protector installed, after a few consecutive disturbances in the electrical network the motherboard just died. It was an Intel board with an onboard Atom processor (they sent me newer model under warranty conditions). My point here is that most probably the PSU have a passive protection at least, because that's required (in Europe), but still it's far from a desktop grade PSU with active protection.

                • 5. Re: 6i3SYK freezes and reboots on certain tasks in Ubuntu 15.10
                  simov

                  I was plagued by the WHEA UNCORRECTABLE ERROR (once I installed Windows), so I just received my replacement NUC, it's still a -502 product number, produced in Mart 2016, and it came with BIOS 0024. I immediately flashed it to 0044. Hopefully this solves it for me. I'm marking this answer as the correct one.

                  • 6. Re: 6i3SYK freezes and reboots on certain tasks in Ubuntu 15.10
                    Intel Corporation
                    This message was posted by Intel Corporation on behalf of

                    Hello, All:

                     

                    Thank you for your feedback.

                     

                    simov, as you mentioned before your are working with an unsupported operating system, but I am glad to hear that your unit is working.

                     

                    For further reference; Supported Operating Systems for Intel® NUC Products.

                     

                    Regards,

                    Amy.