3 Replies Latest reply on Mar 4, 2016 7:43 AM by Intel_Peter

    Linking to openssl on Edison

    DavidGS

      For reasons I won't go into -- just be glad you don't have to do it -- I have had to create a program in C for Intel Edison that does an HTTP POST via SSL. So I had to roll my own HTTP client using openssl.

       

      It compiles and runs fine on my desktop, OpenSSL 1.1.0-pre4-dev but on the Edison I only have OpenSSL 1.0.1m . I tried to build openssl from source on the Edison, but

      Can't locate integer.pm in @INC (you may need to install the integer module) (@INC contains: /etc/perl /usr/lib/perl/site_perl/5.20.0/ /usr/lib/perl/site_perl/5.20.0 /usr/lib/perl/vendor_perl/5.20.0/ /usr/lib/perl/vendor_perl/5.20.0 /usr/lib/perl/5.20.0/ /usr/lib/perl/5.20.0 /usr/local/lib/site_perl /usr/lib/perl/5.20.0 .) at asm/sha1-586.pl line 526.

       

      So once again the version of PERL on the Edison is not sufficient.

       

      I also tried just using the version of openssl that is included with Edison, but I get this cryptic response: //usr/lib/libssl.so.1.0.0: error adding symbols: DSO missing from command line and can't link the binaries.

       

      I regularly go down rat-holes like this with Edison, so I thought I'd start here and see if anyone had any idea how to get around these issues. I'm happy either a) getting perl up to speed so I can build openssl OR figuring out how to link to the existing openssl without error.

       

      Suggestions?

        • 1. Re: Linking to openssl on Edison
          Intel_Peter

          Hello DavidGS,

           

          I tried to install OpenSSL 1.1.0, I checked its dependencies (mostly, it only needs Perl 5) and the Edison seemed to have them (Edison has 5.20.0, it's not that old considering that the latest is 5.22.1). But in the configure process I received a message with the following: This system (linux-elf) is not supported. It looks like OpenSSL 1.1.0 might not be compatible with Edison. In that case I'd suggest you to contact OpenSSL to see if in fact is incompatible or if there is anything they can do to help you.

           

          Peter.

          • 2. Re: Linking to openssl on Edison
            DavidGS

            Right. I also tried to build 1.0.1m from source, but the Perl installation is not sufficient.

             

            My experience so far is that *many* of the packages for Edison are hopelessly out of date -- Node.js is so old it's scary -- and updating them is often not possible due to things not being available that should be available -- like basic parts of Perl.

             

            It's frustrating.

            • 3. Re: Linking to openssl on Edison
              Intel_Peter

              I understand how you feel and really appreciate your feedback, I will make sure to pass it to the appropriate team and hopefully they can do something about this in future releases.

               

              Peter.