4 Replies Latest reply on Mar 2, 2016 3:10 PM by aleki_intel

    Intel 750 Series 2.5" not recognised | Asus Z170-PREMIUM

    MoBIoS

      Hello Team,

       

      I have recently build a new PC and for that I wanted to include the new Intel 750 Series 2.5" with my Asus Z170-PREMIUM Board to install my OS Win10pro x64 on.

      But all my attempts to get it recognised within the newest BIOS (1602 x64) where without success.

      I have tried to isolate the drive, by disconnecting every other drives, so to speak only to use the bare necessities, to be able to boot up the computers BIOS,

      with onboard graphics, no USB connected other then keyboard and mouse, just to be sure there will not be a conflict.

       

      The Intel 750 Series 2.5" is connected to the supplied Intel cable and an dedicated SATA power plug, which has been tested for functionality also. 

      The power supply is a Bquite Dark Power Pro 1000W.

       

      I have tried numerous BIOS settings, some of which where suggested by the ASUS support, with whom I got in contact also.

      I have tried to get the Intel 750 running,

      * installed with the Hyperkit U.2 adapter PCe Card,

      * with the Hyperkit inserted in the NVMe slot, as well as

      * connecting the SSD directly on the provided U.2 port.

       

      Changing Bandwidth to x4 Mode as well as auto.

      I have set the CSM to UEFI only, auto as well as UEFI driver first, without avail.

      Also I have tried to see if the SSD will be recognised, when running the Win10 setup routine, again without success. NVMe drivers cannot be installed (if that would have changed anything), as windows doesn´t recognise a drive for which it will be suited for.

       

      I have read and been suggested to update the 750´s firmware, but without it being recognised anywhere, I would not know how to address that.

      I have put my "old" drives from my previous computer to boot into windows, without problems, yet the intel 750 is not recognised there either.

      Installing the Intel Toolbox and Rapid Storage Technologie didn´t bring me any further.

       

      Is there anything else I can attempt, to be able to get the Intel 750 Series 2.5" to be recognized, or at least to check generell functionality? I dare to say that I am not totally unskilled building PC´s, but I do want to avoid sending the drive in for RMA if the real problem is sitting in front of the computer. Especially because I already had an RMA with the reseller, (Mindfactory / Germany) on the purchased products for this computer, this would be more than embarrassing.

      For your information, I have added some generell specs after booting from my old drives on my new PC. If you need any other information to support this issue, I will be glad to provide them.

       

      Many thanks in advance, for your time, which is much appreciated.

       

      Regards,

       

      Oliver

       

          Motherboard:
            CPU Type                                          QuadCore Intel Core i7-6700K, 4600 MHz (46 x 100)
            DMI Motherboard Manufacturer                      ASUSTeK COMPUTER INC.
            DMI Motherboard Product                           Z170-PREMIUM
            DMI Motherboard Version                           Rev 1.xx
         
            Motherboard Chipset                               Intel Sunrise Point Z170, Intel Skylake-S
            System Memory                                     32688 MB  (DDR4-2133 DDR4 SDRAM)
            DIMM1: Corsair CMK16GX4M2B3000C15                 8 GB DDR4-2133 DDR4 SDRAM  (16-15-15-36 @ 1066 MHz)  (15-15-15-36 @ 1066 MHz)  (14-14-14-35 @ 1037 MHz)  (13-13-13-32 @ 962 MHz)  (12-12-12-30 @ 888 MHz)  (11-11-11-27 @ 814 MHz)  (10-10-10-25 @ 740 MHz)  (9-9-9-22 @ 666 MHz)
            DIMM2: Corsair CMK16GX4M2B3000C15                 8 GB DDR4-2133 DDR4 SDRAM  (16-15-15-36 @ 1066 MHz)  (15-15-15-36 @ 1066 MHz)  (14-14-14-35 @ 1037 MHz)  (13-13-13-32 @ 962 MHz)  (12-12-12-30 @ 888 MHz)  (11-11-11-27 @ 814 MHz)  (10-10-10-25 @ 740 MHz)  (9-9-9-22 @ 666 MHz)
            DIMM3: Corsair CMK16GX4M2B3000C15                 8 GB DDR4-2133 DDR4 SDRAM  (16-15-15-36 @ 1066 MHz)  (15-15-15-36 @ 1066 MHz)  (14-14-14-35 @ 1037 MHz)  (13-13-13-32 @ 962 MHz)  (12-12-12-30 @ 888 MHz)  (11-11-11-27 @ 814 MHz)  (10-10-10-25 @ 740 MHz)  (9-9-9-22 @ 666 MHz)
            DIMM4: Corsair CMK16GX4M2B3000C15                 8 GB DDR4-2133 DDR4 SDRAM  (16-15-15-36 @ 1066 MHz)  (15-15-15-36 @ 1066 MHz)  (14-14-14-35 @ 1037 MHz)  (13-13-13-32 @ 962 MHz)  (12-12-12-30 @ 888 MHz)  (11-11-11-27 @ 814 MHz)  (10-10-10-25 @ 740 MHz)  (9-9-9-22 @ 666 MHz)
            BIOS Type                                         AMI (01/07/2016)
      
      
          Display:
            Video Adapter                                     NVIDIA GeForce GTX 980  (4 GB)
         
          Storage:
            IDE Controller                                    Intel(R) 100 Series/C230 Chipset Family SATA AHCI Controller
            Storage Controller                                Asmedia 106x SATA Controller
            Storage Controller                                ASUS BOT Storage Driver
            Storage Controller                                ASUS BOT Storage Driver
            Storage Controller                                DAEMON Tools Pro Virtual SCSI Bus
            Storage Controller                                Microsoft-Controller für Speicherplätze
            Disk Drive                                        INTEL SSDSC2MH250A2  (250 GB, SATA-III)
            Disk Drive                                        SAMSUNG HD322HJ  (320 GB, 7200 RPM, SATA-II)
            Disk Drive                                        Samsung SSD 850 PRO 1TB  (1024 GB, SATA-III)
            Disk Drive                                        WD 10EADS External SCSI Disk Device  (931 GB)
            Disk Drive                                        WD My Passport 0820 SCSI Disk Device
            Disk Drive                                        WDC WD3000GLFS-01F8U0  (300 GB, 10000 RPM, SATA-II)
            Disk Drive                                        WDC WD3000HLFS-01G6U1  (300 GB, 10000 RPM, SATA-II)
            Optical Drive                                     HL-DT-ST BDDVDRW CH10LS20  (BD:10x, DVD+RW:16x/8x, DVD-RW:16x/6x, DVD-ROM:16x BD-ROM/DVD+RW/DVD-RW)
            SMART Hard Disks Status                           OK
      
        • 1. Re: Intel 750 Series 2.5" not recognised | Asus Z170-PREMIUM
          aznxfrost

          I don't think the 750 series actually work flawlessly with any z170 based motherboards. (See my previous thread i have tried 3 z170 motherboards on different brands.)

           

          I have contacted MB manufacturers and were given various beta bios drivers, but too bad I have already exchanged the 750 for Sam**** M.2 PCIe NVMe which was recognized without any issues on boards struggling with the 750.

           

          You should try getting beta BIOS from Asus, I doubt Intel can provide much help here unless they do plan on releasing new firmware to increase its compatibility. At the moment the drive appears to be very motherboard dependent, and just didn't work on any of the z170s I have tried though all of them stated they were NVMe compatible (Asus Maximus Viii Hero, Gigabyte Z170X Gaming 7, MSI Z170A Gaming Pro).

          • 2. Re: Intel 750 Series 2.5" not recognised | Asus Z170-PREMIUM
            MoBIoS

            Thank you for your reply.

            I am trying to use the 2.5" SSD of the Intel 750 which should go into the onboard U.2 Port (or the Hyperkit Card NVMe U.2 Adapter), which again is sharing the SATA6G_34 Ports if set to x4 Mode on my mainboard.

             

            I have read your post, I read that you have at least managed to get your Intel 750 NVMe PCe to be recognised by your BIOS and update the firmware. I have never got that far as my SSD is not being recognised at all.   Updating the firmware would probably be a good advice, but chances are slim, if BIOS is not detecting.

             

            Also, thank you for your advice to ask ASUS for a Beta Bios. I will follow on that as well.

            • 3. Re: Intel 750 Series 2.5" not recognised | Asus Z170-PREMIUM
              MoBIoS

              I was hoping for some official Intel support here, but unfortunately this did not happen after almost 5 days.

               

              Nevertheless I did get my issue solved and I´d like to come back to my initial post to at least share my solution.

               

              In short, the original boxed Intel cable supplied with the Intel 750 Series 400GB 2.5" form factor was faulty!

               

              I managed to get another cable of the same SSD. The goal was to test if the other SSD is working in my PC, as this one was a confirmed working one of a friend of mine.

              We tried the cable first. As soon we used the new cable on the onboard U.2 port of the Asus Z170-PREMIUM board, the Intel showed up as NVMe device.

              It was not necessary to switch the BIOS U.2. Bandwidth to x4 Mode. (Which I did later)

              CSM was set to UEFI first.

              XMP Profil on.

              Nothing else was set after returning to default BIOS.

              I booted with my old Windows 10 drive and installed the newest firmware for the Intel 750.

              After that, I managed to install Windows 10 pro x64 UEFI without any more issues.

               

              Now the following information might not have anything to do with the initial issue, but I feel it also could serve to bee useful.

               

              Prior to Win Setup, we created a bootable win10pro x64 USB stick with MediaCreationTool,

              Upon drive selection, the Intel drive was recognised, we loaded the newest Intel NVMe driver nevertheless.

              We created a GPT Partition and formated the drive.

              As a side note, on our clean install of Windows10, we could use our Win7 Ultimate Serial Key to activate the Win10prox64 distribution, which was previously activated on my old hardware. 3 Calls to Microsoft support stated 3 different statements, but all had in common, the only way to get win10 activated, was that we need to install win7 to upgrade to Win10 and than install yet again for a clean install. But according to the Heise Magazin (Germany) the activation with a Win7 Key, on a clean installation is possible since the November2015 release of Win10 and I can confirm this now.

               

              Next thing which might become handy. I tend to use acronis2016 to back up my system states. I used to use the Acronis Startup Recovery Manager, which installs a mini Linux. I tried to validate a disaster recover scenario with the Intel 750, before I spend to much time configuring my system.  If activated, on Boot you can enter the recovery manager with F11. But the Intel will not be recognised as a selectable drive to recover, because there are no drivers present.

              The way the disaster recover worked flawless, was to create a USB Win PE rescue media with the included system hardware drivers. The drive was recognised as an option to recover.

               

              Everything is working fine now, nevertheless, the new boxed original Intel cable which was faulty, gave me a lot of grief and the technology is to new, as to have spare ones lying around to test against. And as such, I first presumed, that the issue was with me and not the hardware releated.  I did get a very helpful ASUS support, but none here, which leaves me a little disappointed. One would not expect the supplied cable of a brand new Intel SSD to be the source of the issue.

               

              I hope I could help someone who might stumble across this post with similar issues.

              • 4. Re: Intel 750 Series 2.5" not recognised | Asus Z170-PREMIUM
                aleki_intel

                MoBIoS,

                 

                Thank you for your input. We do appreciate your time taken to report this. We would like to help you further with this so we were wondering if you could be kind enough and send us the faulty cable. Please check your private message.