7 Replies Latest reply: Jun 3, 2011 2:35 AM by RSS

    Turbo Memory doesn't work on Windows 7


      I purchased and installed a 4 GB Intel Turbo Memory module on my NSpire KHLB2 notebook. At first I installed the software included on the CD. I discovered that was a mistake so I downloaded and installed version Turbo Memory driver off of Intel's website. It still doesn't work. I read somewhere on the Internet that you have to reboot multiple times to get this to work. Well, I have rebooted well over 7 times and it still doesn't work. I also tried with and without a Windows page file turned on, with and without User Account Control turn on and it still doesn't work.


      Windows Device Manager shows the Intel Turbo Memory Controller installed and working properly. Intel Turbo Memory Console shows Windows ReadyBoost and ReadyDrive both disabled and total cache size of 4GB. The options to enable these cache policies are both disabled.


      If I go into System Information -> Intel Turbo Memory I see:

      Cache Disk Location: -1

      Model Name: None

      Capacity: 0 GB


      Any ideas?


      OS Name: Microsoft Windows 7 Ultimate

      OS Version: 6.1.7600 Build 7600

      Processor: Intel Core 2 Duo CPU T9600 @ 2.80 Ghz

      BIOS Version/Date: 1.05, 9/16/2009

      Language: ENU


      Intel Turbo Memory System Information:

      Installation Status: Present

      File: C:\windows\system32\drivers\iaNvStor.sys


      Provider: Intel Corporation


      OROM Version:

      OROM Status: Success