2 Replies Latest reply on Feb 28, 2016 5:54 AM by Adam_N

    IPMI vlan and host vlan on one nic



      can i have the same vlan on host nic1 and ipmi lan ?


      The situation looks as follows:

      1) server with two nic (NIC1 and NIC2, but we only use NIC1)

      2) in linux on server NIC1 (name eth0) i create tagged vlan:

      ip link add link eth0 name eth0.101 type vlan id 101

      ip add add dev eth0.101

      3) configure ipmi

      # ipmitool lan print
      Set in Progress         : Set Complete
      Auth Type Support       : NONE MD5 PASSWORD 
      Auth Type Enable        : Callback : NONE MD5 PASSWORD 
                              : User     : NONE MD5 PASSWORD 
                              : Operator : NONE MD5 PASSWORD 
                              : Admin    : NONE MD5 PASSWORD 
                              : OEM      : 
      IP Address Source       : Static Address
      IP Address              :
      Subnet Mask             :
      MAC Address             : 00:1e:67:21:3d:be
      SNMP Community String   : INTEL
      IP Header               : TTL=0x00 Flags=0x00 Precedence=0x00 TOS=0x00
      BMC ARP Control         : ARP Responses Enabled, Gratuitous ARP Disabled
      Gratituous ARP Intrvl   : 0.0 seconds
      Default Gateway IP      :
      Default Gateway MAC     : 00:00:00:00:00:00
      Backup Gateway IP       :
      Backup Gateway MAC      : 00:00:00:00:00:00
      802.1q VLAN ID          : 101
      802.1q VLAN Priority    : 0
      RMCP+ Cipher Suites     : 1,2,3,6,7,8,11,12,0
      Cipher Suite Priv Max   : caaaXXaaaXXaaXX
                              :     X=Cipher Suite Unused
                              :     c=CALLBACK
                              :     u=USER
                              :     o=OPERATOR
                              :     a=ADMIN
                              :     O=OEM

      4) connect NIC1 to switch with tagged vlan 101


      With this configuration i can't connect to ipmi from Linux when i run ping i don't receive response

      ARP table on the switch show only mac od the NIC1 in linux host.

      I am doing something wrong or such a solution does not work?