7 Replies Latest reply on Mar 15, 2016 3:18 AM by ehartsuyker

    NUC D54250YWK not booting after Ubuntu 14.04.3 install

    ehartsuyker

      I have two brand new, identical D54250YWK NUCs with two identical SSDs. Let's call them NUC A and NUC B, and SSD A and SSD B.

      With SSD A in NUC A, I copied the verified iso to a USB drive and successfully installed the OS. It booted, and in the BIOS menu, I could see the bootable partition on the SSD. Everything worked.

      I installed the OS on NUC B with SSD B, and on the BIOS menu I couldn't see the UEFI partition. The OS wouldn't boot. I tried reinstalling the OS with all possible partition schemes, but the OS never booted.

      I then swapped the SSDs so that SSD B was in NUC A. If I bootes and went to the BIOS menu, I could see the bootable UEFI partition on SSD B, and the OS booted.

      Going back to NUC B, the visual BIOS allowed for UEFI booting and had the SSD as priority. But with SSD A in NUC B, I couldn't see the boot able partition nor boot into Ubuntu.

      I then opened both NUCs, reset the BIOS, booted, reset the BIOS in the visual BIOS, then for kicks reset the battery again. Then did all of the above, yet nothing worked.

      Does anyone have any clue what is happening here?