3 Replies Latest reply on Sep 13, 2017 1:55 AM by morix.dev

    Ethernet adapter 82574IT stopped or resetting in WEC7

    jakpou

      Hi

       

      We are using a Nexcom NISE2300 (Intel atom D2550) computer which has 4x Intel® 82574IT GbE LAN ports . It is running

      Windows Embedded Compact 7 (WEC7) with the drivers from the “Intel® Ethernet Drivers for Microsoft* Embedded Operating Systems version 12". The WEC7 image is based on the "Small footprint device" template and the CEPC bsp, it also has smp enabled.

       

      When using the network we sometimes get the following message printed to the debug port

      "PID:00400004 TID:00EB0016 WINCE 6.0 E1Q::PhyUpdateAdaptiveIFS: Adaptive IFS exiting--adapter is stopped or resetting"

      and a network adapter stops to respond (even to ping), sometimes it recovers (after some seconds) and sometimes a power cycle is needed.

       

      Does anyone have an idea of why the adapters are stopping /resetting and why this message gets printed?

       

      Best regards

      Jakob

        • 1. Re: Ethernet adapter 82574IT stopped or resetting in WEC7
          wb_Intel

          Hi jakpou,

           

            Have you tried contacting Nexcom support? They can further assist you to check the components on the system.

           

          rgds,

          wb

          • 2. Re: Ethernet adapter 82574IT stopped or resetting in WEC7
            jakpou

            Hi

             

            I have contacted Nexcom support but they have not come up with any good answer so far.

             

            If I disable symmetrical multiprocessing the problem disappears.

            It seems like that the driver (PRO1000 on WEC7) in the package “Intel® Ethernet Drivers for Microsoft* Embedded Operating Systems version 12"  does not work correctly when symmetrical multiprocessing is enabled and there are several Ethernet adapters.

             

            I have tracked down the text printed to e1i61ce7.dll which comes form the package above.

             

            Also if I query the adapter with IOCTL_NDISUIO_NIC_STATISTICS only the first adapter reports any packets and bytes but they all shows correct for mediastatus.

             

            Best regards

            Jakob

            • 3. Re: Ethernet adapter 82574IT stopped or resetting in WEC7
              morix.dev

              Hi Jakob,

              I know this is quite an old discussion thread... but I have today the same exact problem you had in 2016...

               

              Have you had some follow-up from Intel and/or the producer of your board? Have you found any other solution? Anyway can you confirm that disabling SMP it works?

               

              Regards,

              /morix