3 Replies Latest reply on Feb 23, 2016 8:29 AM by allan_intel

    [i5 5200U] Turbo boost is only enabled after reactivating Windows 10

    phnomphen

      Hi.

       

      I've got some troubles with my Acer Aspire E5 571G with an intel i5 5200U and a nVidia GT 840m: Because of the poor performance of my system, I checked the CPU clock under stress and noticed, that the highest clock achieved was 2,2 GHz (measured with CPU-z and intel Tuning utility) when two cores were used. It should go up to 2,5 GHz. Acer already released special drivers and a BIOS activating the turbo boost. I tried them all and also different Windows Versions but nothing helped, until I forced the multiplier to 25 with ThrottleStop, which was working really well. But I don't really want an off-site tool two boost my CPU, when it should do it by itself. I already tried different power saving settings of my PC and battery-configurations. The BIOS doesn't allow me to change settings, but shows me that the max clock should be 2,5GHz. There is no heat problem using ThrottleStop forcing the turbo multiplier. By accident I noticed, when my PC turns off to power saving mode and I reactivate it with my Win 10 pin, the turbo boost works without any problems. I tried it several times and it's reproducible. Turn on PC from power off => Win 10 pin => wait for it to load everything => start intel tuning utility => stress test max 2,2 GHz => Turn PC off to power saving mode => Reactivate with Win 10 pin => start intel tuning utility => stress test max 2,5 GHz. Benchmark results are 200 (2,2 GHz) against 240 (2,5 Ghz), so it's kind of significant difference.

       

      Does anyone have a clou what could possibly be the problem? All drivers are the newest and recommended by Acer.