4 Replies Latest reply on Mar 7, 2016 2:04 PM by Intel_Alvarado

    Wifi does not startup automatically after reboot

    Dirk1969

      Hi,

      I know, this issue has been discussed back in 2014 in @ How to have Edison reconnect to WiFi automatically? which was solved with the introduction of the configure_edison --setup capability. In my case, I tried this several times in the more specific form configure_edison --wifi with limited result.

       

      Starting configure_edison --wifi leads to a wifi connection for sure, if started from the tool screen, that is true. But in my case however, after a reboot I needed to re-run configure_edison --wifi so many times that I think this is just not what it is supposed to be. I read in an old post of Stephanie moyerman that, in the background, this has to do with /etc/wpa_supplicant/wpa_supplicant.conf.

       

      I found this config file, but was surprised that my wifi connection info was there in many many repetitions, each time exactly with the same content. I figured that each time I lost wifi connection, and used configure_edison --wifi to get reconnected, a new entry (copy) of my wifi info is added in wpa_supplicant.conf Strange enough an entry which is already there, but when I tried wpa_client it said it could not connect to wpa_supplicant. After running edison_configure --wifi wpa_client replies as expected.

       

      What is going wrong here? There is also a file called wpa_supplicant.conf.original I removed my conf files with all those identical entry copies and replace it with the original. After running edison_configure --wifi again the process of creation of multiple wifi entries starts all over again. It looks as if the wifi info is there but not activated or accessible by wpa_client or any other entity which is responsible for starting wifi after a (re)boot.

       

      Regards,

      Dirk.

        • 1. Re: Wifi does not startup automatically after reboot
          Intel_Alvarado

          Hi,

           

          This seems like a strange issue. Once I ran the steps from configure_edison –setup, there’s no need to reconnect again, the wifi settings are enabled after reboot. I used configure_edison –wifi several times and each time after that I checked the /etc/wpa_supplicant/wpa_supplicant.conf file and there were the copies of the network information as you described.

           

          However, each time after I reboot the settings that I’ve previously configured in configure_edison –wifi of configure_edison –setup are still there and I have wifi enabled at boot. Maybe you need to re-flash and see if this issue persists. I’m using version 159.devkit.

           

          Sergio

          1 of 1 people found this helpful
          • 2. Re: Wifi does not startup automatically after reboot
            Dirk1969

            Hi Sergio,

             

            I am using 159.devkit too, however, the version number includes an additional 2.0

             

            Thanks for your reply, this is helpful to gain insights on what is really going on. It seems not to be a specific reboot problem. I had a test running which was started last thursday. I did not connect with it during the weekend, but it was still running until this morning, and then I lost connection. There was no reboot. Re-flashing is an option, and maybe I will do this. I will come back on this issue later this week or early next week.

             

            Regards,

            Dirk.

            • 3. Re: Wifi does not startup automatically after reboot
              Dirk1969

              Hi,

               

              I still had problems getting wifi access after reboot. Sometimes it works, sometimes not. Sometimes with a wrong IP address. So I decided to re-flash the edison. However, I got stuck because of a message that the latest image contains too much data, something like 'not enough space on device'. I tried to install the Flash-Tool-Lite on my mac yosemite. It looks as if it is installed, but then it does not appear anywhere.

               

              It looks as if I need to postpone my real wifi issue and start reading about re-flash issues...

               

              Regards,

              Dirk.

              • 4. Re: Wifi does not startup automatically after reboot
                Intel_Alvarado

                Hi Dirk1969,

                 

                Were you able to solve your flashing issues and use Wi-Fi without problems?

                 

                Sergio