12 Replies Latest reply on Jul 29, 2016 8:42 AM by DaemonInformatica

    Edison is not showing up in explorer

    ishu

      I don't see Edison showing up in explorer in Windows or Mac. I tried connecting using USB hub as well.

      I can make the serial connection over the terminal and login but can't seem to update the the FW (Flashlight utility or dfu-util) as it gets stuck complaining it can't connect to Edison.

      I've already installed the USB driver and FTDI driver listed on the support discussion.

       

      Can't seem to make it work. Any ideas?

        • 1. Re: Edison is not showing up in explorer
          CMata_Intel

          Hi ishu,

           

          I would like to know more information about the problem you are having.

          1. Which OS are you using? Are you using different PCs or laptops? Or are you using a VM?

          2. Is this happening since the first time you used the board? Or have you been able to use this port before?

          3. On Windows, are you able to see something on the Device Manager related to the device? Maybe in “Other Devices”.

          4. Are you using the Breakout Board or the Arduino Expansion Board?

          5. Are you following these tutorials:

          How to Run the Flashall Script

          IoT - Flash Tool Lite User Manual | Intel® Developer Zone

           

          I also suggest you to use different USB cables and USB ports.

           

          Regards,

          Charlie

          • 2. Re: Edison is not showing up in explorer
            ECEngineer

            I had this same problem a few months ago. I solved it by:

            1. Making sure that the Edison is receiving enough power from the USB ports (if you can login you should be fine)

            2. Making sure you have all of the proper files in the same directory as dtf-util. If I remember correctly, I believe the libusb-1.0.dll file was not included in the Edison firmware download. I downloaded this from another site.

            3. Run dtf-util from command line so you can see if there are any errors occurring when it closes. When updating the image it should pick up the Edison fairly quickly, but may need you to unplug and re-plug the two USB cables from your computer in order to become flash-able.

            4. After you successfully update the image, do it again using the XDK installer, should be called iotdk_win_installer for windows machines.

             

            Hope that helps!

            • 3. Re: Edison is not showing up in explorer
              ishu

              Hi,

              Thanks for your suggestions. I did download libusb-1.0.dll and made sure that all the files are in same directory before launching flashall.bat (i followed direction given here).

              I also changed the USB cables and unplugged/replugged them after launching the utility

               

              Please see the enclosed screenshot. Thanks.

               

              ishuflashall-screenshot.png

              • 4. Re: Edison is not showing up in explorer
                ishu

                Hi,

                I'm trying it on 2 different computers (not VMs) - one has Windows 7 and the other is OSx.

                I'm trying it for the first time and am using Arduino expansion board. I've already tried the tutorials you mentioned above, they were really descriptive but didn't help fix the issue I've. Thanks.

                 

                ishu

                • 5. Re: Edison is not showing up in explorer
                  ishu

                  Also, the device manager does list the USB serial port the edison is connected to (com5) - see enclosed screenshot. Thanks.device manager.png

                  • 6. Re: Edison is not showing up in explorer
                    CMata_Intel

                    Hi ishu,

                     

                    Thank you very much for the information and the screenshots. I would like to know if you have the switch pointing to the micro USB ports (you need to have it in that position if you want to use the micro USB port).

                    Did you try with the Flash Tool Lite Tool? What was the outcome of it?

                     

                    Did you install the standalone drivers or did you use the Integrated Installer? If you haven’t tried with the Integrated Installer, you can find it in here: IoT - Intel® Edison Board Download | Intel® Developer Zone

                     

                    Regards,

                    Charlie

                    • 7. Re: Edison is not showing up in explorer
                      ishu

                      Hi Charlie,

                      Yes, I do have te switch towards microUSB ports. I assume the Flash Lite tool is part of the integrated installer, no?

                       

                      In fact I installed both the integrated installer and standalone driver - trying all the workarounds listed in the various forums. Here is the screenshot of the Integrated installer, the next button is grayed out i.e. it doesn't detect the Edison.

                       

                      ishu

                       

                      Integrated-installer.bmp

                      • 8. Re: Edison is not showing up in explorer
                        ishu

                        I'm beginning to wonder if there is any issue with the hardware, maybe the microUSB port itself but then I can connect using serial port through Putty. What microUSB port is used for the serial communication?

                         

                        Thanks.

                        ishu

                        • 9. Re: Edison is not showing up in explorer
                          CMata_Intel

                          Hi ishu,

                           

                          There could be a problem in the hardware as you said; we could check this by using a power supply. With a power supply the board will not need to be powered through the USB port so we could check if the problem is the board or the power provided from the USB ports on the PCs.

                                                                                                                         edison ports.JPG

                          From the picture:

                          1. This is the port that allows the communication with the Arduino IDE and provides the access to a USB storage partition on the Edison, also allows a RNDIS network interface. When there isn’t a power supply, the Board is being powered by this USB port

                          2. This is the port used to have access to the Terminal Console on the board

                           

                          Regards,

                          Charlie

                          • 10. Re: Edison is not showing up in explorer
                            jcuzella

                            Had this same problem on a Macbook Pro, using the Mini Breakout Board where dfu-util was not finding the Edison, although I had connected both cables properly.

                             

                            As it turned out, my issue was because I happened to be using a USB cable that I had obtained along with a rechargeable battery, originally used to plug the portable battery into a USB port for charging.  After I tested this cable's connectivity, the data leads happened to be not connected, and therefore it was useless as a real standard USB cable should have all 4 contacts connected and able to conduct electricity down the cable.

                             

                            So, this is just a guess... but have you tried swapping out either of your micro USB cables with ones that you have verified to work with another data using device?

                             

                            From the output of dfu-util, it appears that your problem is that it's not seeing anything connected:

                             

                            > flashall.bat
                            Using U-boot target: edison-blankrndis
                            Now waiting for dfu device 8087:0a99
                            Please plug and reboot the board
                            Dfu device not found Timeout
                            Did you plug and reboot your board?
                            If yes, please try a recovery by calling this script with the --recovery option
                            
                            • 11. Re: Edison is not showing up in explorer
                              CMata_Intel

                              Hi ishu,

                               

                              I would like to know if you have been able to work on this, did you try using a power supply?

                               

                              Regards,

                              Charlie

                              • 12. Re: Edison is not showing up in explorer
                                DaemonInformatica

                                Has this been solved yet? I have exactly the same problem. After installing the Windows 64bit driver, I plug in both USB cables and a 7V / 2Amp powersupply. Windows returns with a:

                                Error on plugging in.png

                                 

                                In devicemanagement it shows up as:

                                Device manager.png

                                 

                                Opening the properties of the device and updating the driver (opting for searching the net)

                                Edison Composite device.png

                                So whatever is installed and trying to serve the device, there's no known newer version of it.

                                 

                                dfu-utils times out trying to update the firmware image. But I have a suspicion it needs this connection to do that.

                                I can login on the serial port COM37 without a problem.

                                 

                                Help / insight would be appreciated.