5 Replies Latest reply on Mar 3, 2016 9:23 PM by YounusAhamadShaik

    igb: probe failed with error -2; Intel I354 Ethernet connection with Marvell 88E1512 external PHY

    YounusAhamadShaik

      Hi,

       

      We are using Avoton platform in which four Intel Ethernet connections I354 will be present. We using Marvell 88E1512 as external PHY device. We installed windows igb drivers, prowinx64 and Ethernet got working in windows. But if we boot to linux means, we are not able to find any Ethernet connections. If we run command "lshw -class network", it shows as below message (which four controllers are unclaimed.)

       

        *-network:0 UNCLAIMED

             description: Ethernet controller

             product: Ethernet Connection I354

             vendor: Intel Corporation

             physical id: 14

             bus info: pci@0000:00:14.0

             version: 03

             width: 64 bits

             clock: 33MHz

             capabilities: pm msi msix pciexpress cap_list

             configuration: latency=0

             resources: memory:dff60000-dff7ffff ioport:e0c0(size=32) memory:dffec000-dffeffff

        *-network:1 UNCLAIMED

             description: Ethernet controller

             product: Ethernet Connection I354

             vendor: Intel Corporation

             physical id: 14.1

             bus info: pci@0000:00:14.1

             version: 03

             width: 64 bits

             clock: 33MHz

             capabilities: pm msi msix pciexpress cap_list

             configuration: latency=0

             resources: memory:dff40000-dff5ffff ioport:e0a0(size=32) memory:dffe8000-dffebfff

        *-network:2 UNCLAIMED

             description: Ethernet controller

             product: Ethernet Connection I354

             vendor: Intel Corporation

             physical id: 14.2

             bus info: pci@0000:00:14.2

             version: 03

             width: 64 bits

             clock: 33MHz

             capabilities: pm msi msix pciexpress cap_list

             configuration: latency=0

             resources: memory:dff20000-dff3ffff ioport:e080(size=32) memory:dffe4000-dffe7fff

        *-network:3 UNCLAIMED

             description: Ethernet controller

             product: Ethernet Connection I354

             vendor: Intel Corporation

             physical id: 14.3

             bus info: pci@0000:00:14.3

             version: 03

             width: 64 bits

             clock: 33MHz

             capabilities: pm msi msix pciexpress cap_list

             configuration: latency=0

             resources: memory:dff00000-dff1ffff ioport:e060(size=32) memory:dffe0000-dffe3fff

       

      And when we try to print "dmesg" command, we are getting related to igb drivers as following lines.

       

      .......

      .......

      [    1.940641] igb: Intel(R) Gigabit Ethernet Network Driver - version 5.2.13-k

      [    1.940646] igb: Copyright (c) 2007-2014 Intel Corporation.

      .......

      .......

      [    1.971096] igb: probe of 0000:00:14.0 failed with error -2

      [    1.971398] igb: probe of 0000:00:14.1 failed with error -2

      [    1.971690] igb: probe of 0000:00:14.2 failed with error -2

      [    1.971982] igb: probe of 0000:00:14.3 failed with error -2

      ....

      ....

       

      We tried installing igb Standard drivers from Intel for but having same behaviour.

       

      Your help on this will be appreciated.

       

      Thanks and Regards,

      Younus Ahamad S