3 Replies Latest reply on Feb 10, 2016 10:28 AM by EstebanC_Intel

    Factory reset on bricked NUC DE3815TYKHE?

    Julioo

      Hi,

       

      Short story:

      I would like to perform a factory reset (aka CMOS reset) on this board but can't find any instruction not using the BIOS. So this is impossible on a bricked board...

       

      The board bricked while following Intel® NUC BIOS Recovery Update Instructions to try to restore a previous version of the BIOS. But as soon as I removed the jumper, the board only started once, asking me to insert a USB key with a BIOS to restore (which I didn't, I was simply looking at this boot mode before using it). So I stopped the board, inserted the USB key, started it again and it no longer started. The board now always starts and stops silently after 4 seconds. No beeps, no blinking leds (just a normal blue one, as when it correctly worked). Note that before that I tried Computer Won't Boot After BIOS Update instructions but the BIOS did not offer the option "Press F9 to restore BIOS factory default values." as stated (I had "Restore Default Values" instead which did not reset the CMOS as stated...).

       

      Here are two videos of the Bricked NUC - YouTube with and without the jumper. I also tried to unplug/plug every devices (keyboard, hard drive, monitor) and the result is the same

       

      Longer story:

      I just spent two crazy days debugging this board because of its buggy firmware. I had to upgrade to the latest firmware version to get rid of the headless mode bug but while it corrected this bug, it created a lot more (grub2 error about EFI services) et linux not able to stop the machine unless I put the OS type as Windows in the BIOS. This setting seems to change ACPI things... But with this mode, I can no longer boot from the eMMC ! So I decided to go back to the original less buggy version of the firmware and started a reset process described above.

       

      I'll post EFI tests on another post for the record and your firmware team. But for now, this is a huge nogo on Intel NUC boards... We would be really happy to find a solution a least on this.

        • 1. Re: Factory reset on bricked NUC DE3815TYKHE?
          EstebanC_Intel

          Hello, Julioo:

           

          In order to get to the CMOS battery and remove it to perform a physical clear CMOS, you would have to take the unit apart, the Motherboard needs to be removed to reach it.

           

          This is not fully recommended since it could harm the unit.

           

          Here you can find a video of this process (not in English but for guidance could work).

          https://youtu.be/40gNR5rR11s?t=384


          After reaching the CMOS battery and removing it for more than 20 mins, you can test the BIOS recovery again.

           

          A tip for this, make sure the .bio file is the only file in the flash drive.

          Recovery BIOS Update Instructions for Boards and Kits

          Please perform the recovery to the version you attempted previously.

           

          I look forward to your outcome with this.

           

          Regards,

          Esteban C

          • 2. Re: Factory reset on bricked NUC DE3815TYKHE?
            Julioo

            Hi,

            I had already tried to remove the CMOS battery during an entire night but not reconnecting it with a usb key. I let the board with the CMOS battery disconnected while I was waiting for an answer here, so the battery has been disconnected for 24h at the time I tried your advices.


            I did a video showing what happens when I plug the AC power right after having reconnected the CMOS battery, disconnected for 24h.


            Settings:

            - hard drive disk unplugged since it does not play a role in this.

            - DDR3 correctly plugged.

            - headset to hear potential beeps (no worries, it beeps high enough to be heard without wearing them)

            - bios jumper removed

            - monitor connected an turned on with a VGA port instead of HDMI.

            - usb key with one partition and a fat32 filesystem containing TY0024.BIO in the root directory, nothing else.


            Note that this usb key has a LED which is turned on as soon as the device is used and which blinks when there are accesses.

             

            Video: Plugging in AC power after ~24h of CMOS battery disconnected - YouTube

             

            You can see the board seems to be in some state but nothing happens with the usb key, nor on the monitor. The led behind the power button is on as if when the board is turned on. Right now, the nuc is in the state you can see at the end of the video, I am waiting for your instructions to continue.

             

            But so far, I experienced the same before you answered and I had tried a CMOS reset by myself. From where we are now, I turned off the board with a "normal push" on the power button. Turned it back on with a "normal push", and the board was still shutting down like before after 4 seconds, without entering any recovery mode, without any screen feedback, etc. I also tried to enter recovery mode with the power button (push during ~4 seconds after hearing 3 beeps) but it does not work and there are also no beeps at all. So I removed the CMOS again to recover this weird state when you plug the power back after a CMOS reset with the usb key plugged in and let it for a while but nothing... The USB key contained junk files generated by my OSX I removed using a linux OS this time.

            • 3. Re: Factory reset on bricked NUC DE3815TYKHE?
              EstebanC_Intel

              Hello, Julioo:

               

              Thank you for the detailed information provided regarding your situation.

               

              Right now, if you are not able to perform the BIOS recovery, I would like to recommend you to check the warranty on your device.

               

              This can be done here: Contact Support

               

              Please make sure you select the correct region.

               

              Regards,

              Esteban C