11 Replies Latest reply on Feb 12, 2016 7:56 AM by EstebanC_Intel

    Windows 7 slow at "starting windows" - nuc6i5syk

    Studio

      Hi,

       

      I have just installed Windows 7 Pro x64.

       

      This is my equipment:

      - NUC6i5SYK

      - Samsung 950 pro 512GB NVME M2

      - Ram 8x2 Kingston 2133 sodimm

      - Windows 7 Pro x64

       

      It was hard to install it, but thanks to RLM70 Re: Nuc6i5syk + Samsung 950 pro + 2 Kingston 8 GB 2133 sodimm + W7 pro  I have finally a Nuc working with W7.

       

      After installation I imported further intel drivers (Graphics, Audio, Lan, Wifi, Bluetooth) and to make sure that I didn't loose anytying I have installed again also Usb3 drivers and Samsung 950pro drivers.

      After that I have updated W7 untill today (something like 270 updates).

       

      Everything works, but there is a quite odd thing: when I switch on the Nuc, at the step "starting windows" the writing remains freezed without the animated logo for 10-15 sec, after that the animated logo appears and  the procedure continues normally.

       

      I know that 10-15 sec more don't change your life, but it's quite strange that a brand new machine with a windows experience index of 7,2 at that step is much slower than an old computer core 2 duo with a windows experience index of 4,7.

       

      Is there any setting or additional drivers to import to make windows 7 Pro x64 start normally?

       

      Thank you in advance fo the help

        • 1. Re: Windows 7 slow at "starting windows" - nuc6i5syk
          RLM70

          Hi,

          Have installed win7 with uefi boot mode, if you have you can try to disable "Legacy" mode in bios so that only uefi is enabled.

           

          Regards

          • 2. Re: Windows 7 slow at "starting windows" - nuc6i5syk
            Studio

            Hi,

            When I have installed w7 in the bios there were flagged both uefi and legacy.

             

            Now I tried unfalgging legacy in the bios boot mode, but the system blocks saying that there isn't a bootable support. So I flagged lagacy again and I tried unflagging uefi. But the "starting windows" freezed with no logo remains as well. To be precise the writing remains for 30 seconds, after that the animated logo starts.

             

            Thanks for the help.

            Regards

            • 3. Re: Windows 7 slow at "starting windows" - nuc6i5syk
              RLM70

              Hi,

              What you could try is to install win7 again but in uefi mode, to do this you need to make an bootable uefi usb stick from your win 7 iso with this software: Rufus - Create bootable USB drives the easy way

              If you do that you can disable legacy and save you many seconds each bootup.

               

              Regards

              • 4. Re: Windows 7 slow at "starting windows" - nuc6i5syk
                RLM70

                If you decide to create a new usb stick dont forget to insert the usb3 and nvme driver :-)

                • 5. Re: Windows 7 slow at "starting windows" - nuc6i5syk
                  Studio

                  Hi RLM70,

                   

                  I followed your advices.

                   

                  With Rufus I made a key W7  in "GPT for UEFI" scheme  then added drivers (Usb3 and NVME)

                   

                  I have done again the W7 istallation on the NUC. It was impossible to do the installation with only the UEFI flagged. The only way of installing W7 was with both Uefi and Legacy enabled.

                   

                  Something changed compared to before. Now in the bios in the UEFI Boot Priority there is also "UEFI : Windows Boot Manager : PART 0 : OS Bootloader"

                   

                  The thing is that if unflag Legacy Boot Windows doesn't start and this message is written:

                   

                  BlInitialazeLibrary failed 0xc0000001

                   

                  If I leave Legacy Boot enabled the NUC starts like before when I did the installation with the Usb Key made with Rufus in the "MBR for Bios or UEFI". With that installation there wasn't "UEFI : Windows Boot Manager : PART 0 : OS Bootloader" in the list of UEFI Boot Priority.

                   

                  Any Idea?

                   

                  Thank you

                   

                  Best regards

                  • 6. Re: Windows 7 slow at "starting windows" - nuc6i5syk
                    RLM70

                    Hi,

                    Give me some hours and i will install windows 7 on my nuc and try to help you out :-)

                    • 7. Re: Windows 7 slow at "starting windows" - nuc6i5syk
                      RLM70

                      Hi,

                      I've been fiddeling around the net and tried 3 different win7x64 iso's i have laying around but end up with same problem as you, what i found is a comment from another member of this intel board,


                      "Windows 7 requires having Legacy mode enabled at the BIOS so that it can be installed. Windows 7 and older Operating Systems are considered legacy by Microsoft therefore is necessary to have Legacy Mode enabled"

                       

                      So i think we've hit the wall for uefi w/o legacy ticked for windows 7, maybe someone from the support team can comment on this ?

                       

                      Regards

                      • 8. Re: Windows 7 slow at "starting windows" - nuc6i5syk
                        Studio

                        Hi RML70,

                         

                        thank you very much for the patience,

                         

                        It seems that MSI says that on skylake motherboards it's possible to install Windows 7, it's just necessary to select in the bios  setting/advance/windows os cofiguration -> then select Windows 7. But in the NUC6i5syk there isn't a OS selection option...

                         

                        my Bios version is the 2.2.17. I don't know if a bios update could solve the thing or if would create additonal problems.

                         

                        Regards

                        • 9. Re: Windows 7 slow at "starting windows" - nuc6i5syk
                          EstebanC_Intel

                          Hello, Studio:

                           

                          I would like you to check the "Correct Answer" added in this thread mentioned before

                          Nuc6i5syk + Samsung 950 pro + 2 Kingston 8 GB 2133 sodimm + W7 pro

                           

                          Please do provide us with your feedback on how this works for future references.

                           

                          Regards,

                          Esteban C

                          • 10. Re: Windows 7 slow at "starting windows" - nuc6i5syk
                            Studio

                            Hi Esteban,

                             

                            that discussion was written by me initially...

                             

                            That procedure works, but it works only with leagcy boot. Pratically this discussion is a continuation of that discussion. That discussion is solved, yes, but in reality it's half solved.

                             

                            The point is that with that procedure windows 7 works but at the starting is very slow. The writing "starting windows" remains freezed for 30 sec without animated logo, like on a very old computer...

                             

                            With the help of RML70 we found out that the problem is that is not starting in UEFI mode.

                             

                            So now we are becoming mad to find out how to install Windows 7 in UEFI mode, I mean in a way that works, without the error BlInitialazeLibrary failed 0xc0000001

                             

                            I think that it's very important that NUC is able to work properly with Windows 7 seen that a huge part of actual software in the business world is not yet update for windows 10, and in the business sector you can't wait. But I think that it's quite weird to buy an older computer to be able to work immediatly with windows 7...

                             

                            Any help is very appreciated!

                             

                            Regards

                            • 11. Re: Windows 7 slow at "starting windows" - nuc6i5syk
                              EstebanC_Intel

                              Hello, Studio:

                               

                              I certainly understand your concern about this.

                               

                              I would like to get some additional information about the scenario you have with your system, and some settings you could change as well:

                               

                              1. Just to confirm, are you trying to boot from the network? Meaning a server is present and you would like to boot via LAN.

                              2. Do you have multiple units that have the issue or just a single unit?

                              3. What happens if you disable the LAN adapters in the device manager? This would be to make sure the unit is not trying to boot from LAN.

                              4. You can also disable network boot (if not being used) at BIOS level.

                              5. Please make sure all windows updates have been installed in your system.

                              6. Also, please verify your unit is using all drivers up to date.

                               

                              How to disable network boot?

                               

                              Access BIOS > Advanced> Boot> Boot configuration> Boot devices> set network boot to "disable"

                               

                              Another setting you should select would be under UEFI boot> "Boot network devices last" this is in the same section as previous step.

                               

                              After changing the BIOS settings and installing windows updates / updating drivers, please test your system and advise me with it's behavior.

                               

                              Regards,

                              Esteban C