1 2 Previous Next 16 Replies Latest reply on Apr 6, 2016 11:37 AM by Bill.

    install.sh message: Package does not support platform it is being run on

    Bill.

      Hi,

       

      Short Story:

       

           The IoT Developer Kit's install.sh script fails saying the platform is not supported, which is a 32-bit PC running Ubuntu.

                

      Long Story:

       

      My environment:

       

           PC = 2004-ish Dell 8300  32-bit  (added 0n 3/7/2016)

           CPU = Pentium 4, 3 ghz

           Memory = 3 GB

           OS = Ubuntu 14.04 LTS

                         

      I went to this page:

       

           https://software.intel.com/en-us/get-started-edison-linux

       

      And saw that there were no special Linux OS requirements.

       

      I then clicked on Step 2 which took me to:

       

           https://software.intel.com/en-us/get-started-edison-linux-step2

       

      In the lower half of the page, in the "Download the installer" section I clicked on "Linux Integrated Installer" which downloaded the following:

       

           https://downloadmirror.intel.com/25384/eng/l_iot_dev_kit_2015.0.019.tar.gz

       

      It was unzipped into a subdirectory of my home directory.

       

      I found install.sh and install_GUI.sh.  When I run either, the following message is displayed:

       

           The package does not support the platform it being run on.

           Please check to be sure the correct architecture of package has been downloaded.

       

      I then ran "bash -x  ./install.sh" to see what was happening:

       

      Before the error message, the script is looking for the following:

       

           /home/fozz/Software-Temp/l_iot_dev_kit_2015.0.013/./pset/32

       

           i.e. it is looking for a .../pset/32 directory.

       

      the .../pset/32 directory does not exist, I only see 32e directory.

       

      That value of 32 is contained in the my_arch variable which is set based on the output from "uname -m".

       

      In my case "uname -m" = i686

       

      If "uname -m" returned "x86_64", my_arch is set to "32e" which is what I see in the pset directory, otherwise it is set to "32", which is my case.

       

      I am assuming that x86_64 and 32e both mean 64-bit.

       

      Question: does the Linux Integrated Installer require a 64-bit PC?

       

      Regards,

      Bill

       

      Message was edited by: Bill: 03/07/2016: explicitly indicated that I have a 32-bit PC.

        • 1. Re: install.sh message: Package does not support platform it is being run on
          PabloM_Intel

          Hi Bill.,

           

          I just checked from an older post in the Community that a user had a similar issue with an Integrated installer, another user recommended to run the following command in your computer and then running the installer:

          apt-get install ia32-libs
          

           

          We’ll investigate this case a little bit more, but please let us know your results.

           

          Regards,

          Pablo

          • 2. Re: install.sh message: Package does not support platform it is being run on
            Bill.

            Hi Pablo,

             

            Thank you for the detective work.

             

            Ubuntu is apparently built on Debian. Looking at this web page:

            https://packages.debian.org/squeeze/ia32-libs

             

            It says:

                Package: ia32-libs (20140630)

             

                ia32 shared libraries for use on amd64 and ia64 systems

             

                This package contains runtime libraries for the ia32/i386 architecture,

                configured for use on an amd64 or ia64 Debian system running a 64-bit kernel.

             

            At the bottom of the page I can select to download an amd64 version or an ia64 version. I tried to download ia32-libs pack to at least look at the files. The North American links were all broken. However, I could download other packages.

             

            I then tried "apt-file list ia32-libs". It returned nothing. "apt-file list apt-file" did return a list of files.

             

            I found "apt-get install ia32-libs" here:

            https://communities.intel.com/message/290678

            But the poster said "I am using 64-bit Ubuntu."

             

            And I found a reference here:

            https://communities.intel.com/message/108020#108020

            It is not clear if the hardware is 32-bit or 64-bit.

             

            Status: Since my PC is 32-bit and ia32-libs appears to be designed for 64-bit PCs, I think it will not solve the problem. I am reluctant to install ia32-ibs for fear that it might break Ubuntu and I would have to reinstall it.


            Question: what is the link to the older Community post that you found?

             

            Regards,

            Bill

            • 3. Re: install.sh message: Package does not support platform it is being run on
              PabloM_Intel

              Hi Bill.,

               

              Here’s the link to the thread I mentioned: https://software.intel.com/en-us/forums/intel-software-development-products-download-registration-licensing/topic/338800. The topic of the thread is not about the Integrated Installer for the Edison, however, the conditions are similar and the error is the same that you’re getting.

              Did you check it before?

               

              Regards,

              Pablo

              • 4. Re: install.sh message: Package does not support platform it is being run on
                Bill.

                Hi Pablo,

                 

                Regarding ia32-libs ...

                 

                I tried: sudo apt-get install ia32-libs

                 

                and that resulted in this error message:

                     E: Unable to locate package ia32-libs

                 

                To see if apt-get and apt-file were working ...

                 

                I then tried: sudo apt-file list ia32-libs

                It did not return anything.

                 

                I then tried: sudo apt-file list apt-file

                and it did return a list f files for apt-file

                 

                Question: any idea where to find ia32-libs or maybe something, by a different name, that replaces it?

                 

                Regards,

                Bill

                • 5. Re: install.sh message: Package does not support platform it is being run on
                  PabloM_Intel

                  Hi Bill.,

                   

                  I’ve been reading some thread about the same error, most of the posts talk about an issue with apt, however this doesn’t seem to be your case as you already made sure that apt is working. There were some other suggestions that you can try, though.

                   

                  A user suggested the following:

                  1. Make sure the server you selected in the “Software Sources” is the “Main Server”.
                  2. Search for all the packages starting with lib32 with apt-cache search lib32.
                  3. Install every package in that list, without adding any ‘-dbg’ or ‘-dev’ suffixes.
                  4. After you’ve done all the above, try installing ia32-libs again.

                   

                  Another comment hints at an issue with the i386 architecture for apt, and suggests to run the next commands to add it:

                  sudo dpkg --add-architecture i386
                  sudo apt-get update
                  sudo apt-get install ia32-libs
                  

                   

                  Regards,

                  Pablo

                  • 6. Re: install.sh message: Package does not support platform it is being run on
                    Bill.

                    Hi Pablo,

                     

                    Thanks for the 2 suggestions but the short story is, neither helped.

                     

                    Question: for the first suggestion, item 1, do you know what the user wanted me to look at to "Make sure the server you selected in the "Software Sources" is the "Main Server"."?

                     

                     

                    For Suggestion 1 ...

                     

                    I ignored item 1 in that first suggestion and executed the following:

                     

                         pt-cache search lib32

                     

                    It responded with : libnss-mdns-i386 - NSS module for mDNS name resolution (i386 transitional package)

                     

                    I then executed :

                         sudo apt-get install libnss-mdns-i386

                     

                    That seemed to work. It ended with:

                     

                        Preparing to unpack .../libnss-mdns-i386_0.10-6_i386.deb ...

                        Unpacking libnss-mdns-i386 (0.10-6) ...

                        Setting up libnss-mdns-i386 (0.10-6) ...

                     

                    But this was unsuccessful:

                         sudo apt-get install ia32-libs

                     

                    It ended with:

                     

                        Reading package lists... Done

                        Building dependency tree

                        Reading state information... Done

                        E: Unable to locate package ia32-libs

                     

                     

                    For Suggestion 2 ...

                     

                    This did not result in any error messages:

                         sudo dpkg --add-architecture i386

                     

                    This displayed a lot of lines:

                         sudo apt-get update

                     

                    This is a sample of what was displayed:

                     

                        Ign http://us.archive.ubuntu.com trusty InRelease

                        Hit http://us.archive.ubuntu.com trusty-updates InRelease

                        Hit http://us.archive.ubuntu.com trusty-backports InRelease

                        Hit http://us.archive.ubuntu.com trusty Release.gpg

                        Hit http://us.archive.ubuntu.com trusty Release

                         ...

                        Reading package lists... Done

                     

                    They show one of these URLs:

                        http://extras.ubuntu.com

                        http://security.ubuntu.com

                        http://us.archive.ubuntu.com

                     

                    This failed:

                         sudo apt-get install ia32-libs

                     

                        Reading package lists... Done

                        Building dependency tree      

                        Reading state information... Done

                        E: Unable to locate package ia32-libs

                     

                    Regards,

                    Bill

                    • 7. Re: install.sh message: Package does not support platform it is being run on
                      PabloM_Intel

                      Hi Bill.,

                       

                      It’s referring to the repositories. The places where the apt will fetch packages to download, install, etc. Repositories have different components, one of them “Main”. Unfortunately, this didn’t work according to your description. I’ve been doing some more research and apparently ia32l-libs has been mostly replaced by Multi-Arch, which allows you to install software under different architectures following a defined process. I believe that’s why you’ve been having some issues trying to install it.

                      However, it’s still possible to do it. I would suggest you to check the main answer from this Ubuntu thread, http://stackoverflow.com/questions/23182765/how-to-install-ia32-libs-in-ubuntu-14-04-lts-trusty-tahr. You’ll find a detailed process to install ia32-libs.

                       

                      Regards,

                      Pablo

                      • 8. Re: install.sh message: Package does not support platform it is being run on
                        Bill.

                        Hi Pablo;,

                         

                        Thanks for the pointer to the StackOverflow topic.

                         

                        Question:  can you change the status for this discussion to "not answered"?

                         

                        Question:  by "main answer" do you mean the StackOverflow answer beginning with "You can try this to install the 32-bit library (not all in ia32-libs)"?

                         

                        My PC is a 32-bit, which I didn't explicitly indicate when I started this discussion.

                         

                        Based on the following clues, I think ia32-libs is only used on 64-bit Ubuntu systems. Mine is 32-bit.

                         

                        clue: https://help.ubuntu.com/community/MultiArch

                        "One package for 32-bit shared library support on a 64-bit system is named ia32-libs"

                         

                        clue: http://askubuntu.com/questions/107230/what-happened-to-the-ia32-libs-package?rq=1

                        "The ia32-libs package was a hack to get 32-bit packages installed on a 64-bit installation."

                         

                        clue: http://askubuntu.com/questions/151595/couldnt-find-package-ia32-libs

                        "If you are using the 32 bit version of Ubuntu, you don't need nor will you find an ia32-libs package. That's only required for the 64 bit version of Ubuntu."

                         

                        Question:  Is it possible that ia32-libs is NOT the solution to my problem?

                         

                        Question:  Is it possible that that I need a 64-bit PC?

                         

                        Regards,

                        Bill

                        • 9. Re: install.sh message: Package does not support platform it is being run on
                          PabloM_Intel

                          Hi Bill.,

                           

                          Sure, it should be set as “Not Answered” now. If the thread doesn’t have much activity during a certain amount of time it is marked as “Assumed Answer”, but you don’t need to worry about that. We will keep replying as long as you need our help, even if the thread is marked as answered.

                          Regarding your other questions and clues, it’s possible that the issue has nothing to do with ia32-libs, however, it’s a good idea to exhaust all possibilities before jumping to other solutions or suggestions. I am aware that you’re using a 32-bit PC, but some of the suggestions that we’ve been trying were also applied on 32-bit systems. Unfortunately, we haven’t had any luck yet.

                          It would be a good idea to try with a 64-bit system, but I’m not sure if you have access to one right now. Is this a possibility to you?

                           

                          Regards,

                          Pablo

                          • 10. Re: install.sh message: Package does not support platform it is being run on
                            Bill.

                            Hi Pablo,

                             

                            Short Story:  still get "package does not support the platform" message.

                             

                            Long Story:

                             

                            On 3/4/2016 you wrote:

                                check the main answer from this Ubuntu thread,

                                http://stackoverflow.com/questions/23182765/how-to-install-ia32-libs-in-ubuntu-14-04-lts-trusty-tahr.

                             

                            I assumed the "main answer" was the first one which recommended the following:

                                sudo -i

                                cd /etc/apt/sources.list.d

                                echo "deb http://old-releases.ubuntu.com/ubuntu/ raring main restricted universe multiverse" >ia32-libs-raring.list

                                apt-get update

                                apt-get install ia32-libs

                             

                            It still responds with "unable to locate package"

                             

                            I looked at 2/25/2016 and ran the following:

                             

                                sudo dpkg --add-architecture i386

                                sudo apt-get update

                                sudo apt-get install ia32-libs

                             

                            It still responds with "unable to locate package"

                             

                            On 3/4/2016 you mentioned Multi-Arch, I executed the following command:

                             

                                apt-cache pkgnames ia32

                             

                            and found these packages:

                             

                                grub-efi-ia32

                                grub-efi-ia32-bin

                                grub-efi-ia32-dbg

                                ia32-libs-multiarch

                                primus-libs-ia32

                             

                            I executed: apt-get install ia32-libs-multiarch

                             

                            It did a lot of work.

                             

                            I then "unpacked" l_iot_dev_kit_2015.0.019.tar via:

                             

                                tar -xvf l_iot_dev_kit_2015.0.019.tar.gz

                             

                            cd'd to l_iot_dev_kit_2015.0.019 and executed the following install scripts:

                             

                            ./install_GUI.sh

                                The package does not support the platform it being run on.

                                Please check to be sure the correct architecture of package has been downloaded.

                                Quitting!

                             

                            ./install.sh

                                The package does not support the platform it being run on.

                                Please check to be sure the correct architecture of package has been downloaded.

                                Quitting!

                             

                            No one has read this item and responded saying that they have worked with Linux/Ubuntu on a 32-bit PC.

                             

                            I do not have access to a 64-bit machine.decide

                             

                            Question:  do you have any other suggestions or should we decide that Linux must be installed on a 64-bit PC?

                             

                            Regards,

                            Bill

                            • 11. Re: install.sh message: Package does not support platform it is being run on
                              PabloM_Intel

                              Hi Bill.,

                               

                              I’m sorry to hear that you’re still getting the same message. I would suggest you to try with the manual process, maybe you’ll have better luck with this one, you can follow the steps here https://software.intel.com/en-us/flashing-firmware-on-your-intel-edison-board-linux. You’ll need to install the IDE individually using the manual process. You can find the software in this link https://software.intel.com/en-us/iot/hardware/edison/downloads, at the end of that page you’ll see a section called “Supported IDEs”, click con IDE downloads page.

                               

                              Regards,

                              Pablo

                              • 12. Re: install.sh message: Package does not support platform it is being run on
                                Bill.

                                Hi Pablo,

                                 

                                Regarding: the manual process for flashing

                                 

                                Result:: That has not been successful. I have posted my war story in this item:

                                https://communities.intel.com/message/373547

                                 

                                 

                                Regarding: manually install an IDE: Eclipse (C++)

                                 

                                I downloaded it from:

                                https://software.intel.com/en-us/iot/software/ide/eclipse

                                 

                                And followed the installation instructions on this page:

                                https://software.intel.com/en-us/installing-the-eclipse-ide

                                 

                                I started Eclipse via: ./devkit-launcher

                                 

                                Result: It failed because it said it DID NOT like the Java 32-bit that was installed and that it wanted Java 64-bit.

                                 

                                 

                                Regarding: manually install an IDE: Arduino

                                 

                                I successfully installed the Linux 32-bit version and uploaded the Blink sketch to Edison, on Edison it shows up as sketch.elf in /sketch

                                 

                                I cannot tell if it working because DS2 has been rapidly blinking.

                                 

                                I made a copy of Blink and commented out the digitalWrite(13, HIGH), hoping to turn DS2 OFF, and uploaded it.

                                A new version of sketch.elf shows up in Edison's /sketch directory but DS2 continued to blink.

                                 

                                Result:: The Arduino IDE seems to work with Ubuntu Linux, but I'm not sure about the health of Edison, read the next section abut DS2.

                                 

                                 

                                Problem: DS2 blinking repeatedly

                                 

                                I tried various things to debug this problem. I'll omit the gory details to keep this shorter.

                                 

                                I plugged micro USB B cables into J16 and J3

                                DS2 turned on for maybe 10 seconds, then it turned off.

                                DS1 then turned on for maybe another 10 seconds

                                Then a new Ubuntu window popped up showing the Edison storage where I had saved a file 2 weeks ago.

                                 

                                With DS1 on, then DS2 began to blinks rapidly. This is the first time I have seen the rapid blinking.

                                In the past I think DS2 was on for about 10 seconds, then turned off, followed by DS1 turning on. If DS2 subsequently turned on it didn't blink.

                                 

                                Edison is alive because I can look at the it's file system using: sudo screen /dev/ttyUSB0 115200

                                 

                                On Edison, cat /etc/version showed: weekly-159. That has been the same version since I started.

                                 

                                I tried flashall.sh, AGAIN, but do not know if it did anything.

                                 

                                As I mentioned above, details are in:

                                https://communities.intel.com/message/373547

                                 

                                 

                                Question: is the rapid blinking on DS2 caused my some weird software or is there a hardware problem?

                                 

                                Regards,

                                Bill

                                • 13. Re: install.sh message: Package does not support platform it is being run on
                                  PabloM_Intel

                                  Hi Bill,

                                   

                                  I was reading your thread about the flashall.sh log files, https://communities.intel.com/message/373547. And the behavior that you’re getting from that process is really unusual. I’m wondering now if both issues, the one from this and the other thread, are related. Have you been using the same computer, the 32bit system?

                                  Regarding the Eclipse installation, I guess using this IDE is not option as long as you are using a 32bit system.

                                  Regarding the DS2 LED, since when are you noticing this behavior? Is this a new issue? If you’re still able to access the serial console I don’t think is a Software issue, however I would like to know if does this only happen when connecting the board trough USB, power supply or if it happens with both.

                                   

                                  Regards,

                                  Pablo

                                  • 14. Re: install.sh message: Package does not support platform it is being run on
                                    Bill.

                                    Hi Pablo,

                                     

                                    Regarding: Have you been using the same computer, the 32bit system?

                                     

                                    Answer: I have been using the same Intel Pentium 3 Ghz 32-bit PC with Ubuntu Linux version 14.04..

                                     

                                     

                                    Regarding: Regarding the DS2 LED

                                     

                                    I began my experimentation at the beginning of February.

                                    At that time there was no DS2 flickering. The LED sequence was:

                                     

                                        DS2 on

                                        DS2 off and DS1 on

                                     

                                        At that time I didn't make a note if DS2 eventually came back on.

                                        If it did, it did not flicker.

                                     

                                    During the month of February I was debugging FlashAll,sh and the IDE install.

                                     

                                    I started noticing the rapid blinking of DS2 at the beginning of March.

                                     

                                    When I only use the power supply and do not connect any USB cables I see the same results:

                                     

                                        DS2 on for about 3 seconds

                                        DS2 off, DS1 on

                                        about 20 seconds later with DS1 on, DS2 begins to flicker

                                     

                                    Out of curiosity

                                     

                                        I then plugged the UCB cable into j3, executed the Ubuntu screen command and successfully logged into Edison.

                                     

                                        I then plugged the USB cable into j16. Within a second, maybe 2, a Ubuntu window popped up showing the storage on Edison.

                                     

                                    DS1 is still on and DS2 is flickering.

                                     

                                    I just noticed that when I execute "shutdown now" on Edison, in less than a second, DS2 stops flickering and stays on solid until the shutdown is complete at which time DS1 and DS2 both turn off.

                                     

                                    Thanks for the help,

                                    Bill

                                    1 2 Previous Next