5 Replies Latest reply on Feb 16, 2016 1:35 PM by aleki_intel

    Wifi stop working. Win10 shows only one network and it doesn't connect to WiFi


      Product Name: Hp Omen 15

      Operating System: Microsoft Windows 10 (64-bit) and Elementary OS Freya

      Wifi Adapter: Intel Wireless-n 7260


      Hi guys,
      since some days my wifi has stopped working.
      If I click on Wifi icon it shows only ONE (max two) NETWORK, but not mine!




      And I live in a building with 20+ networks, as you can see from WiFi Analyzer (I'm the red one on the right)

      medium (1).jpg

      My Wifi is on the top. If it's saved, Windows connects to it and then it drops the connection; if it's not saved and I try to connect, it says "You're not able to connect to this network".
      The fun fact is that after some seconds every network disappear and only one is showed (probably the neighbour one..I dunno).


      I've already tried to HARD-RESET the notebook keeping the power button for 10/15sec with the laptop turned off.
      I've already tried to follow these instructions from HP support (http://support.hp.com/us-en/document/c04649175) updating drivers (Intel,, [Windows 10 default], 18.32.0 [Lastest drivers]) with no success. Everytime I install a new drivers, I uninstalled the previous one + Wireless software + reboot.


      I tried to uncheked "Allow this computer to turn off this device to save power" on my Wifi hardware settings without success.


      The HP Network support says I didn't choose a Wifi (Really? The problem is I don't see my Wifi on the list!).


      This is not related to a new Windows 10 upgrade since I've installed it months ago and It's the first time I've this problem :/ It always worked Smiley Sad


      I tried different settings too:
      I changed channel, I set 802.11g on my router, APSD off on the router.
      I set "Magic packet off, ad hoc QoS off, U-APSD off, fat channel off,incremental throughput off, HT mode off" on the card setting without success. Nothing chaned.


      The Hardware test doesn't detect any failure.


      Note carefully: If I go close to the router, it shows my network with full power connection and it connects to it. Then I go back to my bedroom (probably 3/4 meters far), it KEEPS the connection for 30/40min and It drops the connection and I can't reconnect to it anymore. It always worked perfectly in my room in these months (I bought it in March 2015), so the distance is not a problem, I'm 6/7m far from the router.
      In this case It shows my Network (Connected) and the neighbour network...and the other 20+ networks???


      The only way I have is USB tethering with my Nexus 5.


      Linux: I tried the Wifi connection on Elementary Freya (Ubuntu linux based OS) and it shows 20+ networks available on the list. It has not connection problem with my Wifi, but sometimes it stops working, the webpages stop loading and I must reboot Wifi to reconnect to it (usually after 30/40min using it).




      What's the problem? Is my Network-board broken? Any suggestion?