3 Replies Latest reply on Feb 8, 2016 1:37 PM by Intel_Peter

    man pages for yocto project Poky 1.72 linux running on Edison?

    Grant_Rostig

      Hi,

      Were can I find the man pages for Poky 1.7.2 edison? 

       

      Actually is "poky" the name for the linux distribution intel is running on edison?  Or should it be "intel poky" since poky is the reference distribution?

       

      I ask because the getting started page here:

      https://software.intel.com/en-us/intel-iot-platforms-getting-started-cloud-analytics#installing_the_local_agent

       

      say to type:

      echo -n '{"n": "temp", "v": 21.0}' | nc -w1 127.0.0.1 41234

       

      It appears that the version on poky does not allow any parameters at all because the error message is:

       

      BusyBox v1.22.1 (2015-06-19 07:36:41 CEST) multi-call binary.

      Usage: nc [IPADDR PORT]

       

      It simply does not accept any parameters or something else is wrong.  I looked up the busybox documentation, but it shows parameters also.

       

      Regards, Grant

        • 1. Re: man pages for yocto project Poky 1.72 linux running on Edison?
          Intel_Peter

          Hello Grant_Rostig,

           

          You can find the documentation of Yocto in https://www.yoctoproject.org/documentation/archived but I personally recommend you to read the Yocto Project Mega-Manual, it has a ton of information that could be of much help to you.

           

          According to the Mega-manual "poky" can refer to the local copy of the Source Directory used to develop within the Yocto Project. Among other things, the Yocto Project uses a build system based on the OpenEmbedded (OE) project, which uses the BitBake tool, to construct complete Linux images. The BitBake and OE components are combined together to form Poky, a reference build system.

           

          If you'd like to have information specific to Edison, then I'd suggest you to read Edison's Board Support Package (BSP) User Guide.

           

          Could you explain us what you are trying to do? You are following this guide, right?  You get to the point 4 of Verifying that the local agent can send UDP messages and then what happens? Sorry, I'm not sure I understand your doubt.

           

          Peter.

          • 2. Re: man pages for yocto project Poky 1.72 linux running on Edison?
            Grant_Rostig

            Hi @Intel_Peter,  (why did the @ not work for you?)

             

            Thanks for your quick reply.  I looked at all your suggested links and could not find any "man" pages for nc or any other man page.

             

            Yes, I get to point 4 and I get the error message that I noted.  Either the getting started page is wrong, or I'm missing something.  After 5 hours or work, I now believe that the page is not specific enough with regard as to where the window to run that command should be created.  Should it be run from the development host (windows or Linux), and not on the Edison Linux prompt?  I tried to run it from the Edison window but it didn't work.  It may not have worked because one cannot issue such a command from the local box, but only from a remote machine but I doubt that.

             

            I suggest someone may what to fix and clarify that page.

             

            I ask additional questions about additional potential errors on that page on this post where someone else had a similar if not the same problem here on the Intel forum: Re: send-udp.js is not recognized

             

            Regards, Grant

            • 3. Re: man pages for yocto project Poky 1.72 linux running on Edison?
              Intel_Peter

              I understand, let me clarify, the first three steps are supposed to run on the Edison console and the fourth step is supposed to be run from the "development host" (your PC/Mac). So in Linux (Ubuntu, etc.), you will have to open your computer's terminal and run the command echo -n '{"n": "temp", "v": 21.0}' | nc -w1 127.0.0.1 41234. I would run it as sudo, just in case.

               

              Peter.