11 Replies Latest reply on Feb 22, 2016 5:43 PM by EstebanC_Intel

    Intel DH77KC bricked with official BIOS update procedure?

    EMolGer

      Hi there,

       

      I tried to update my BIOS on DH77KC board from the original 69 version to 110 with Express update started from Windows 7.

      (KCH7710H.86A.0110.EB.EXE). After it my motherboard won't start and restarts every 2-3 seconds. I've read other users having the same issue, but many of them could recover the BIOS.

      I've done this:

      - remove board from chassis

      - remove BIOS jumper

      - remove all pheriperals, and battery for hours

      - create a 2GB FAT16 USB drive with the original BIOS (.BIO file)

      - move RAM modules to black slots

      - stick the USB in

      - ps/2 keyboard in along with display

      - put battery back in, following PSU connection

      - turn PSU on

       

      The system "starts", but no sign of any activity, and does not start to read the file from the USB drive... i've tried several USB drives and ports and does nothing.

      Really, really it is possible to brick the motherboard with an official downloadable BIOS upgrade with an official procedure??? Without replacement board over warranty time?

       

      Is there any other way i can try to restore this?

      Thanks for any ideas...