5 Replies Latest reply on Feb 1, 2016 6:39 AM by BMEJ

    ffmpeg command not found

    BMEJ

      Hello,

       

      I am trying to snap a simple photo using a USB webcam.  I am the full IOT yocto image and a galileo gen 2. 

       

      I have verified the dev/video0 file after plugging in the webcam. 

       

      Here is a log:

      root@galileo:~# find /lib/modules/* -name 'uvc'

      /lib/modules/3.8.7-yocto-standard/kernel/drivers/media/usb/uvc

      root@galileo:~# lsmod | grep uvc

      uvcvideo               71190  0

      videobuf2_vmalloc      12875  1 uvcvideo

      videobuf2_core         37680  1 uvcvideo

      videodev               91716  2 uvcvideo,videobuf2_core

      usbcore               144164  7 btusb,uvcvideo,usb_storage,ohci_hcd,ehci_hcd,ehc     i_pci,usbhid

       

      root@galileo:/home/ffmpg/ffmpeg# ./ffmpeg -version

      ffmpeg version 2.8.5-static http://johnvansickle.com/ffmpeg/  Copyright (c) 2000     -2016 the FFmpeg developers

      built with gcc 4.9.3 (Debian 4.9.3-10)

      configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug -     -enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265      --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-l     ibfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --ena     ble-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-am     rwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --ena     ble-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfrib     idi --disable-indev=sndio --disable-outdev=sndio --cc=gcc-4.9

      libavutil      54. 31.100 / 54. 31.100

      libavcodec     56. 60.100 / 56. 60.100

      libavformat    56. 40.101 / 56. 40.101

      libavdevice    56.  4.100 / 56.  4.100

      libavfilter     5. 40.101 /  5. 40.101

      libswscale      3.  1.101 /  3.  1.101

      libswresample   1.  2.101 /  1.  2.101

      libpostproc    53.  3.100 / 53.  3.100

       

      root@galileo:/home/ffmpg/ffmpeg# ffmpeg -f fbdev -vframes 1 -r 1 -i /dev/fb0 screenshot.jpeg

      -sh: ffmpeg: command not found

       

       

       

       

      Any tips for me?  Perhaps I'm just goofing the command up. I did change the folder name to a simple "ffmpeg", but that should be fine right?

      Thanks

        • 1. Re: ffmpeg command not found
          xbolshe

          Hi,

           

          have you tried to do like this?

           

          root@galileo:/home/ffmpg/ffmpeg# ./ffmpeg -f fbdev -vframes 1 -r 1 -i /dev/fb0 screenshot.jpeg

           

          BR,

          xbolshe

          • 2. Re: ffmpeg command not found
            BMEJ

            hi thanks for the suggestion,

             

            here is the result:

             

             

             

            root@galileo:/home/ffmpg/ffmpeg# ./ffmpeg -f fbdev -vframes 1 -r 1 -i /dev/fb0 screenshot.jpeg

            ffmpeg version 2.8.5-static http://johnvansickle.com/ffmpeg/  Copyright (c) 2000-2016 the FFmpeg developers

              built with gcc 4.9.3 (Debian 4.9.3-10)

              configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfribidi --disable-indev=sndio --disable-outdev=sndio --cc=gcc-4.9

              libavutil      54. 31.100 / 54. 31.100

              libavcodec     56. 60.100 / 56. 60.100

              libavformat    56. 40.101 / 56. 40.101

              libavdevice    56.  4.100 / 56.  4.100

              libavfilter     5. 40.101 /  5. 40.101

              libswscale      3.  1.101 /  3.  1.101

              libswresample   1.  2.101 /  1.  2.101

              libpostproc    53.  3.100 / 53.  3.100

            Option vframes (set the number of video frames to output) cannot be applied to input file /dev/fb0 -- you are trying to apply an input option to an output file or vice versa. Move this option before the file it belongs to.

            Error parsing options for input file /dev/fb0.

            Error opening input files: Invalid argument

            root@galileo:/home/ffmpg/ffmpeg#

            • 3. Re: ffmpeg command not found
              xbolshe

              May be need to use /dev/video0 instead of /dev/fb0 ?

               

              BR,

              xbolshe

              • 4. Re: ffmpeg command not found
                BMEJ

                and here is the result of that..

                 

                Option vframes (set the number of video frames to output) cannot be applied to input file /dev/video0 -- you are trying to apply an input option to an output file or vice versa. Move this option before the file it belongs to.

                Error parsing options for input file /dev/video0.

                Error opening input files: Invalid argument

                 

                 

                hmm

                • 5. Re: ffmpeg command not found
                  BMEJ

                  I could not get this to work, but I did manage to get a photo using Video4Linux...

                   

                  thanks to rgb

                   

                  1. Get the file

                  git clone https://github.com/twam/v4l2grab.git

                  2. CD into into directory
                  cd v4l2grab

                  3. Generate the autotools files
                  ./autogen.sh
                  4. Run configure
                  ./configure
                  5. Run make
                  make

                  6. Run make install
                  sudo make instal

                  7. make sure you have /dev/video, if not modprobe uvcvideo

                  8. take a picture v4l2grab -o test.jpg