1 Reply Latest reply on Jan 26, 2016 11:30 PM by wb_Intel

    Ethernet Drivers never installed.

    DuncoChunko

      I'll start by saying I think I've located the missing ethernet drivers from ASROCK's website, but when I run intel's setup wizard, my computer freezes.  I've also tried using the Intel Driver Update utility, which also claims to find the drivers, but once I click install, it simply reads that it failed.

      I also tried installing the latest chipset utility for intel still to no avail.

       

      I should also mention I'm on the internet using some USB D-Link wireless adapter, I can't imagine its drivers are causing a problem, but at this point I'm open to ideas.

       

       

       

      I'm currently running Windows 7 x64bit with an ASROCK z97 extreme 6 motherboard, Intel Core i7-4770K Quad Core processor.
      I built the computer myself, and these are the only drivers that refuse to install.

       

       

       

      Again, I believe I located drivers on ASROCK's website, but the intel driver install wizard makes my computer freeze every time.