13 Replies Latest reply on Jan 25, 2016 5:05 PM by EstebanC_Intel

    NUC6i5SYK  Can not load OS

    paulk72

      The BIOS sees my USB keyboards both wired and wireless no problem.  However, during WIN 7 install, the keyboard is disabled by the time it gets to the windows splash screen.

      plugging the keyboard into every USB port does not work.  Can not proceed to WIN 7 install.

        • 1. Re: NUC6i5SYK  Can not load OS
          rane114

          Windows 7 installation does not include native USB 3.0 driver. You can load up your bootable USB with the USB 3.0 drivers for Windows 7 however. There are numerous tutorials for this on the internet. I've tried but failed. It only worked for the first part of the installation. When I got to the choose time format bit I suddenly had no keyboard/mouse again. I just went with Windows 10 instead.

          • 2. Re: NUC6i5SYK  Can not load OS
            TheWombat

            I went with Windows 10 so did not have an issue, however if you look at this review: http://nucblog.net/2016/01/skylake-nuc-review-nuc6i3syh-benchmarks/

            It references using the Intel Windows 7 USB 3 tool: https://downloadcenter.intel.com/download/25476/Windows-7-USB-3-0-Creator-Utility

            • 3. Re: NUC6i5SYK  Can not load OS
              paulk72

              Thanks everyone.  I ended up doing the WIN 10 upgrade from USB.  No problems

              • 4. Re: NUC6i5SYK  Can not load OS
                Evogen

                Hello everyone,

                 

                I have also had issues installing Windows 7 x64 SP1 due to the lack of usb3 driver support.

                 

                I Think there is one solution left. Maybe if we connect to the internal usb2 driver connector on the motherboard will solve the issue?

                 

                Does anyone have any experience with these internal usb cables?

                 

                It seems like it is a 4pin cable on the motherboard, but I can only find 5 pin cables for sale.

                 

                Could anyone help me with finding a proper cable for the motherboard that I can use to connect to a keyboard or mouse?

                 

                Or has anyone else solved this usb3 driver issue in a different approach?

                 

                Many thanks,

                • 6. Re: NUC6i5SYK  Can not load OS
                  Evogen

                  Thank you very much for the post.

                   

                  I have already been on that thread, but I had problems in putting the drivers properly in my iso win7.

                   

                  I will give it a new try.

                   

                  I tried the Intels software that made the complete process in putting usb3 drivers to the USB bootable win7. I didn't get passed the second part of installation when the computer reboots. In the first boot I got the keyboard and mouse to work during installation.  But it seems to be something that the driver only is processed during installation. Or when my computer boots from the USB.

                  • 7. Re: NUC6i5SYK  Can not load OS
                    EstebanC_Intel

                    Hello:

                     

                    Have you tried disabling xHCI mode? Then install Windows 7*.

                     

                    Regards,

                    Esteban C

                    • 8. Re: NUC6i5SYK  Can not load OS
                      Evogen

                      Hi there Esteban,

                       

                      Where exactly do I find this setting in bios?

                       

                      I Think this bios is pretty constricted for settings.

                       

                      For the USB ports, I can only choose disable or not detect.

                       

                      I cant choose to disable xHCI mode for USB.

                      • 9. Re: NUC6i5SYK  Can not load OS
                        Evogen

                        Hello everyone,

                         

                        I want to say that I made a new try to make a bootable win7 iso with usb3 drivers for my nuc and it was sucessful.

                         

                        I spent many hours yesterday and was very frustrated that I couldnt get things working.

                         

                        I had 3 different websites with similiar instructions, like the one ganboing provided for me.

                         

                        http://codeabitwiser.com/2014/03/how-to-install-windows-7-with-only-usb-3-0-ports/

                         

                        Well, I read all comments in that thread and I Think I understood what the problem could be.

                         

                        In the beginning I used a iso file that was provided in a dvd form sweden. Made an iso of it and booted.

                         

                        Had problems booting. Then I realised I had to make a bootable USB with EFI support. So I did that with the program called Rufus. Worked very well.

                         

                        Then I managed to boot up. But they keyboard and mouse didnt work during installation.

                         

                        I realised that I was missing usb3 drivers.

                         

                        Then I tried to use a software that intel has provided for haswell nucs that had problems with usb3 drivers when installing win7.

                         

                        I downloaded that software and followed instructions to alter my bootable usb with the win7 iso.

                         

                        Then I booted this in my nuc, mouse and keyboard was working. Great! But after the comouter had rebooted after the installation process and went in to the process where I should write my computer name, then the mouse and keyboard didnt work. This seemed like the drivers were only activated during the first boot. So I realised I had to make a manual modification of the win7 iso for usb3 drivers to work during installation and after rebbot of installation. So it gets loaded within the OS after installed.

                         

                        After reading a lot of threads, I tried to use "DOS dism" commands to mount and add the drivers in the important win 7 iso files to get the drivers loaded.

                         

                        After careful search, I wanted to make sure I use proper drivers. And not the drivers that was used by haswell nuc or some other standard intel usb3 drivers that were old. So I choosed these.

                         

                        Download USB 3.0: Intel USB 3.0 Driver for NUC6i[x]SY

                         

                        Then I tried to install them by a similiar thread that ganboing showed me before. I got a lot of errors when trying to mount and install the drivers. I used a win7 computer during that. In DOS I couldnt even finish the first step with mounting without getting error messages. Then I tried to use a graphic user interface of the DOS dism command. Then I managed to mount but had errors in adding drivers.

                         

                        From the downloaded drivers, in the link above. I made sure that I was only using x64 drivers, because I was installing a win7 64bit computer. So I deleted the folders stating "x86" to make sure they were not installed so I didnt get any conflicts in this.

                         

                        But the problem was that I couldnt load any drivers, so I thought maybe I should try using other drivers. Maybe there were something wrong with them.

                         

                        Before doing that, I decided to give the complete process a try on my win10 laptop.

                         

                        I only followed the instructions in the thread provided by ganboing, with the exception that I deleted the "x86" folders in the driver folder that I used for the process.

                         

                        I also only used the DOS command prompt.

                         

                        After successfull mouting and addition of drivers, everything seemed great. Then I booted from my usb in the nuc and everything worked with the usb ports. Keyboard and mouse working. During and after installation.

                         

                        I also want to state one more important thing. After the issues with installing the usb3 win7 drivers in to my usb win7 iso (this win7 iso was copied from my win7 dvd that was provided when I bought win7), I used a downloaded ISO from microsofts webpage (this iso was used when everything worked for me). In other Words, iso taken from microsofts webpage recently and used my win 10 computer for the modification of the iso.

                         

                        I want to thank ganboing for providing me the link for my success and that his effort will help other people save time for this complicated issue.

                         

                        This is the first time I write a support log for a problem and it feels great. It is not often I use a new device that has issues but not many solving solutions on the web. But it feels like an obligation to write what I did to make it working, considering all the times that I have googled up problems and solved them by other users on the net.

                         

                        I hope this post will help others.

                         

                        Thank you very much.

                        • 10. Re: NUC6i5SYK  Can not load OS
                          EstebanC_Intel

                          Hello, Evogen:

                           

                          I would like to thank you for the deep explanation and the time you took too write down this answer.

                           

                          For sure it is going to help other users of the Communities.

                           

                          I look forward to hearing from you in the future.

                           

                          Regards,

                          Esteban C

                          • 11. Re: NUC6i5SYK  Can not load OS
                            westguy

                            I very much doubt the problem is with Intel's claim that Win-7 won't load because it does not contain USB3.0 Drivers.  I have successfully installed Win-7 from a Flash Drive on a NUC5i3RYK and a NIC5i5RYH without issue.  The NUC USB Ports are also USB3.0.  Why does Win-7 install without issue on my NUC5's, yet stops recognizing the Mouse and Keyboard just after STARTING WINDOWS appears????  Would you not expect some CONSISTENCY of operation???

                             

                            I think the problem is with the Intel BIOS.  The whole thing seems directed towards nudging the user to purchase and install Win-10.

                             

                            When the replacement for my bricked NUC arrives from Newegg I plan to first try using the USB2.0 Ports inside the NUC.  A cable with the small 1.25mm spacing connector is available (http://www.usbfirewire.com/parts/rr-af-51021-0500-xxg.html#RR-AF-510210-0500-08G) and then I'll try the Image updated with USB3.0 Drivers using Installer_Creator.exe.  But I don't think the user should have to go to these lengths.  Again, I did not have this issue installing Win-7 on NUC5's.

                            • 12. Re: NUC6i5SYK  Can not load OS
                              Evogen

                              Hi EstebanC_Intel,

                               

                              Thank you very much for the feedback.

                               

                              I appreciate it very much!

                               

                              The explanation for my success was written in a rush due to lack of time with some misspelling.

                               

                              Instead of studying to my exam at the university I got stuck with this problem because I am to stubborn :p

                               

                              I am not a computer expert, but I found a way that worked for me. So I wanted to share it and hopefully it will work for others as well.

                               

                              Cheers mate,

                               

                              /Evogen

                              • 13. Re: NUC6i5SYK  Can not load OS
                                EstebanC_Intel

                                Hello, Evogen:

                                 

                                I totally understand that and indeed this is appreciated by the users that will use the information shared by you.

                                 

                                I hope that exam was easy for you!!

                                 

                                If any further information or support is required, feel free to contact us back.

                                 

                                Regards,

                                Esteban C