5 Replies Latest reply on Jan 26, 2016 11:30 AM by N.Scott.Pearson

    BIOS update failed on DP35DP, can't recover

    freesky776

      Hey all!

      I know that this mobo is outdated but I ought to use it on my little home filesharing server. All was fine except strange poweroff effect. I have Arch Linux installed and when I try to power down my server programmatically or via power button computer does not power off completely - fans are still spinning.

      I've googled a lot and find out that this is related to the outdated BIOS version. So I've downloaded 0572 version (ISO file) and flashed my BIOS. This step was successful but the problem with poweroff was still presented. Also I've noticed random hangs when in CMOS settings screen.

      So then I've found that 0497 version is good enough and solves the problem. I've downloaded BIO file and burnt it to my CD (CD-ROM was set as SATA RAID mode). Then I've removed jumper and started my PC. Screen backlight was working but no characters on the screen were present. I waited about 10 minutes and then tried to reboot PC via keyboard but with no luck. Then I powered down the chassis completely via power button. After that I've plug the jumper back and tried to boot PC. I can see that backlight ups and offs but no characters are on the screen. I cant ever get into CMOS config screen. Setting jumper to the 2-3 position didn't solve the problem. But one strange thing: if I only connect two hard drives and try to boot up i can see grub welcome screen, Arch starts to boot but fails as it can't mount some drives. I thought that the problem is related to the VGA card and removed it but no POST messages were heard. So, guys, I have semi-dead chipset and wonder if there any way to restore BIOS.

      Any help is greatly appreciated.