3 Replies Latest reply on Jan 21, 2016 9:18 AM by EstebanC_Intel

    Can't disable hotkeys (Ctrl-Alt-arrows) for HD3000

    EvilShrike

      I have Lenovo T520 with Intel HD3000 (i7-2670QM). Currently it's on Windows 10 x64. I have the latest drivers available - 9.17.10.4229

       

      I'm suffering from the ugly bug of unswitched hotkeys. I disabled hotkeys in Intel Graphics and Media Control Panel settings but they still are active and work. Ctrl-Alt-Left rotates my screen! Who does the hell need this?! Absolutely same bevahior was on Windows 7. I tried changing hotkeys to other combinations - it doesn't help. Still Ctrl-Alt-arrows rotate my screen..

       

      This is simple terrible, Intel.

       

      It really drives me crazy evert time

        • 1. Re: Can't disable hotkeys (Ctrl-Alt-arrows) for HD3000
          EstebanC_Intel

          Hello, EvilShrike:

           

          I performed some tests with different units on my end.

           

          What I did:

          1. Access the graphics panel.

          2. Support and options.

          3. Unchecked enable/selected disable hotkeys.

          4. Applied changes in graphics panel.

           

          After doing this, the CTRL+ALT+Arrows were indeed disabled.

           

          Units used: NUC 5i5RYK/ i5-2467M in a laptop/ i7-3rd gen in All in one PC.

           

          Please make sure you are applying the changes after performing them.

           

          If you require any further information or support, feel free to contact us back.

           

          Regards,

          Esteban C

          • 2. Re: Can't disable hotkeys (Ctrl-Alt-arrows) for HD3000
            EvilShrike

            Hi.

            Thanks for the response. Sure I did it many times.

            Here's my control panel.

            Sorry for non-English UI, but here's the only one option - "Enable" ("Включить"). It's turned off.

            All these settins are simple ignored. As you can see I set non-default hotkets for rotating (ctrl-shift-alt- instead of ctrl-alt-).

            But even if I enable hotkeys they won't work. But default ones work all the time.

            intel_hd300_cp_hotkeys.png

             

            What also strange is that Control panel can't my second display attached via DisplayPort.

            intel_hd300_cp_displays.png

            I tried to disconnect it, it didn't effect anything related to hotkeys functionality.

             

            Also I removed all Intel's processes from my auturun (gfx*.exe) and disabled services). Hotkeys still work (

            • 3. Re: Can't disable hotkeys (Ctrl-Alt-arrows) for HD3000
              EstebanC_Intel

              Hello, EvilShrike:

               

              Lets uninstall the current driver that you have in your system.

               

              This would be done in the device manager> display adapters> right click in HD Graphics> driver tab> uninstall.

               

              Once done, you will be requested to reset your PC and then let Windows 10* install the default drivers.

               

              Test the behavior of the system after doing this.

               

              Regards,

              Esteban C