7 Replies Latest reply on Jan 29, 2016 3:35 PM by EstebanC_Intel

    Desktop Icons Auto Align Left When Hdmi Cable Connected

    rory72

      Hi,

       

      Whenever I connect my laptop to the TV via hdmi cable my desktop icons are moved into vertical columns down the left hand side of the screen and remain when I unplug, so I have to drag them back to where I want each time. It's a fairly minor nuisance but ideally I'm looking for a way to avoid this. I've searched but can't find a definitive answer. I've tried; right clicking and unchecking 'align icons to grid' but that doesn't make any difference, it still always happens.

       

      Someone mentioned it's likely to do with resolution or scaling and the change happening when I connect the hdmi cable, and I might be able to sort it if I "set the hdmi output to the same as the screen", but I'm not sure how to do that.

       

      I have Intel HD Graphics 530 and  I've poked around in graphics properties and options but as I say, I don't really know what I'm doing. It's all standard settings at the moment, so set to - Clone Displays.

       

      Any advice would be appreciated.

       

       

      Thanks

        • 1. Re: Desktop Icons Auto Align Left When Hdmi Cable Connected
          EstebanC_Intel

          Hello, rory72:

           

          I was checking on this and encountered with a possible workaround.

           

          Check Divya R's reply.

          http://answers.microsoft.com/en-us/windows/forum/windows_7-desktop/desktop-icons-move-multiple-monitors/17d0c47f-92b0-4a…

           

          Also, make sure you have the latest drivers for Intel® HD Graphics 530

          Drivers & Software for 6th gen CPUS

          Drivers & Software for Core M processors

           

          Regards,

          Esteban C

          • 2. Re: Desktop Icons Auto Align Left When Hdmi Cable Connected
            rory72

            I had a look at Divya R's  response but it didn't help much.

             

            As mentioned in my OP, I had already tried his Step 1, which was various combinations of checking and unchecking Auto-align and Align to Grid functions, to no avail.

             

             

             

            I don't really understand what his step 2 means;

             

            "Step 2: Also I would suggest you to reduce the resolution of the monitor so that it will not extend beyond the display area."

             

            I looked at the link he provided for changing screen resolution, but my laptop is set on 1920 x 1080 and my HDTV is also 1080p, so they should be the same anyway. I don't like the idea of reducing the quality of resolution on my laptop to fix this issue, (if that is what's being suggested there, I'm not sure).

             

            On his first link, it was interesting to read about how the higher resolution makes the icons appear smaller, , because when I connect the laptop and TV via the hdmi cable, the icons on my desktop  temporarily get smaller as well as the moving thing. I'm not really sure what that is indicattive of though.

             

            Divya R's second link on step 2 doesn't work.

             

             

            The other users on that thread are talking about reg edit fix which is too technical for me and I don't like the sound of it, plus it's for windows 7 and I have windows 10.

             

             

            Also, I'm pretty sure I do have the latest drivers, because I was recently having another issue with graphics driver crashing when scrolling in browser so I went into device manager and updated driver (in the last week) which fixed that issue.

             

             

            I do appreciate your taking the time to respond though,

             

            Thanks

            • 3. Re: Desktop Icons Auto Align Left When Hdmi Cable Connected
              EstebanC_Intel

              Hello, rory72:

               

              Are you duplicating the screen? Have you tested with the extend option? While connecting your laptop to your TV.

               

              I think this is more related to the OS than the Graphics driver, my recommendation would be to contact Microsoft to check the registry changes mentioned in the thread mentioned before; or any other possible fix for this.

               

              Regards,

              Esteban C

              • 4. Re: Desktop Icons Auto Align Left When Hdmi Cable Connected
                rory72

                Well, that seems to have fixed the issue but I'm not sure exactly how. It was set to duplicating, so I went into control panel > adjust screen resolution and I changed setting to extend. Now, it showed my desktop on the TV (but with top and bottom now cut off, (above taskbar and below icons along top)), mouse only worked on TV screen now, not showing on desktop, and when I played a video, I had sound coming out on the TV but no picture, - picture just showing desktop. So I set it back to duplicating, as it had been originally, and now my icons don't move around anymore. So the issue seems to be sorted. It's a bit weird as it's set the same as when I started, but I'm very happy.

                 

                 

                 

                Also, honestly I'm still not sure if it was a graphics settings or windows settings issue.

                 

                There seems to be two ways you can approach it, either;

                 

                Right click on desktop > Graphics Options (which has intel logo) >  opens options including;  Clone Displays >       Built-in Display + Digital Television

                                                                                                                                                                                                                        Digital Television + Built-in Display

                 

                           Extended desktop  > Built-in Display + Digital Television

                                                                Digital Television + Built-in Display

                 

                 

                Or, to go through control panel (as I did) > Appearance & Personalisation > Adjust Screen Resolution …. Where you get similar options, but this seems to be windows settings.

                 

                 

                 

                 

                So, Idk but issue appears to be sorted and I'm very pleased.

                 

                Thank you very much for your assistance.

                 

                 

                 

                • 5. Re: Desktop Icons Auto Align Left When Hdmi Cable Connected
                  EstebanC_Intel

                  Hello, rory72:

                   

                  Thank you for advising us with the outcome on this.

                   

                  Additionally, I would like you to check the link below related to this scenario, just for more information about this.

                  Move windows between multiple monitors - Windows Help

                   

                  If you have any additional or new inquiries, feel free to contact us back.

                   

                  Regards,

                  Esteban C

                  • 6. Re: Desktop Icons Auto Align Left When Hdmi Cable Connected
                    rory72

                    I checked the link out, it's showing the procedure I went through (basically, change settings from duplicate to extend) which I talked about above. As I say, when I changed setting to extend, I only could get desktop image on tv when I played a video, I got sound but no picture for some reason. So I changed setting back to duplicate, as it had been in the first place, but it still solved the problem somehow, the icons stay where they are now instead of auto-aligning. All very weird.

                    • 7. Re: Desktop Icons Auto Align Left When Hdmi Cable Connected
                      EstebanC_Intel

                      Hello, rory72:

                       

                      Yes it is odd indeed, but it worked.

                       

                      If you require any further assistance or support, feel free to contact us back.

                       

                      Regards,

                      Esteban C