2 Replies Latest reply on Jan 18, 2016 2:53 PM by acu192

    Recovering a bricked Edison... help!

    acu192

      Well, my Edison seems dead.

       

      I was excited because I had just gotten a webcam to work (by installing the uvcvideo module). I powered it off (with `poweroff`), and moved it to another room to keep working on it. It booted up, I ssh'd in, and then pretty quickly I lost connection to it. Never to be seen again...

       

      After some digging, it seems super-dead.

       

      I tried flashing a new Linux Image to it. I tried both `sudo ./flashall.sh` and `sudo ./flashall.sh --recovery`. Both just time out (after about 30 seconds). I reboot the device during that time, but it doesn't pick it up.

       

      Any ideas?


      Also, here's the output of the serial port on boot: (Yes, it just hangs after the line "Ready to receive application").

       

       

       

      ******************************

      PSH KERNEL VERSION: b0182b2b

                      WR: 20104000

      ******************************

       

      SCU IPC: 0x800000d0  0xfffce92c

       

      PSH miaHOB version: TNG.B0.VVBD.0000000c

       

      microkernel built 11:24:08 Feb  5 2015

       

      ******* PSH loader *******

      PCM page cache size = 192 KB

      Cache Constraint = 0 Pages

      Arming IPC driver ..

      Adding page store pool ..

      PagestoreAddr(IMR Start Address) = 0x04899000

      pageStoreSize(IMR Size)          = 0x00080000

       

      *** Ready to receive application ***

        • 1. Re: Recovering a bricked Edison... help!
          DiegoV_Intel

          Hello acu192,

           

          Did you try to re-flash the Edison with the Flash Tool Lite? Also, if you have access to a Windows PC, I recommend you to try to re-flash the module using Windows. I've seen some reports from other users explaining that they couldn't re-flash the module using a particular OS, but with a different one the process worked. Trying with the Flash Tool Lite or the flashall script might work in a Windows PC.

           

          Anyhow, if you are not able to re-flash it after trying all the available methods, I recommend you to submit a warranty ticket. The Warranty Team will help you with this issue. Use the following form to submit the ticket: Intel Support

           

          Regards,

          Diego.

          • 2. Re: Recovering a bricked Edison... help!
            acu192

            Thanks Diego,

             

            I've tried several different ways. I can't even get to the recovery console via the serial connection. It never even boots to that point where I "press any key" (or whatever it says) to get into the recovery console. I think it's toast.