1 2 3 Previous Next 40 Replies Latest reply on Apr 21, 2016 12:31 PM by EstebanC_Intel

    Optimus Bug Intel HD 4000 (probably 2500 as well) on Windows 10

    RadonGOG

      I filled up that recommended table for you:   

      Category

      Questions

      Answers (N/A if not applicable)

      Description

      Provide a detailed description of the issue

      Lagging whenever iGPU switches to dGPU or dGPU switches to iGPU.

      Unneccessary switching. (read as: ways more then normal)


      Does it fail every single time, or only sometimes?
      If you can offer a % rate please do.

      If you follow my steps to reproduce it fails 100% of the time


      Hardware (HW)

      Brand and Model of the system.

      XMG

      Hybrid or switchable graphics system?
      ie Does it have AMD or NV graphics too?

      Optimus

      Make and model of any Displays that are used to see the issue (see note2 below).
      LFP
      = Local Flat Panel (Laptop panel)
      EFP = External Flat Panel (Monitor you plug in)

      LFP

      How much memory [RAM] in the system (see note2 below).

      16 GiB

      Provide any other hardware needed to replicate the issue.
      ie: Cables&brand, cable type [vga, hdmi, DP, etc], dock, dongles/adapters, etc

      iGPU on IvyBridgeHardwareLevel

      Hardware Stepping (see note1 below).

        irrelevant

      Software (SW)

      Operating System version (see note2 below).

      Windows 10, due to the nature of this issue this is crucial for reproducing this issue!

      VBIOS (video BIOS) version. This can be found in “information page” of CUI (right click on Desktop and select “Graphics Properties”.

        irrelevant

      Graphics Driver version; for both integrated Intel and 3rd party vendors (see note2 below).

        Problem occurs when pairing any intel driver (example: 10.18.10.4276, WDDM 1.3) with any nvidia driver newer then 9.18.13.5012 (better known as 350.12, last WDDM 1.3 driver), e.g. the newest 361.43. (WDDM 2.0)

      SW or Apps version used to replicate the issue.

        -

      Configurations

      Single display, clone, or extended (see note2 below).

        SingleDisplay

      Display resolution & refresh rate setting of each display (see note2 below).

        Native res (1080P in my case) and 60 Hz; probably does occur in any other settings as well. Anything below res and 60 Hz would be inacceptable anyways.

      AC or DC mode, i.e. is power cable plugged in or not?

        Happens in both cases

      How to repro

      Please provide steps to replicate the issue.  These steps are very crucial to finding the root cause and fix.
      A screenshot to illustrate the issue is a huge plus. A video of the failure is even better! Attach to the post or provide the YouTube link.

      1. Select a diashow as a Desktop-Background. Open up next desktop background via Right-Click and you´ll be experiencing the buglag.

      Important: This only happens when testing WDDM 1.3 with WDDM 2.0 Hardware-Combinations, like Intel HD 4000 and GTX 660m/ 670m, 680m. There is a thread over at nvidia forums regarding the issue as well. https://forums.geforce.com/default/topic/860554/geforce-mobile-gpus/windows-10-and-optimus/1/

      WARNING: There are other bugs collected in that thread as well; it´s some kind of chaos.

       

       

      Hope to hear back soon,

       

      Radon

        1 2 3 Previous Next