4 Replies Latest reply on Jan 18, 2016 5:12 PM by Eduardo1742

    Help - Intel Edison and Arduino IDE uploading problem

    Eduardo1742

      Hi all.

      After several days trying to upload a simple blink arduino sketch into my intel Edison board, install and reinstall the drivers and all softwares several times, its time to ask here.

      I'm trying to up de sketch but I getting the following message:

      Has someone an idea about what I'm doing wrong???

      Any answer will be welcome

      Thanks.

       

      ----------------------------------------------------------------------------------------------------------------------------

      Sketch uses 76,327 bytes (0%) of program storage space. Maximum is 10,000,000 bytes.

      starting download script

      #!/bin/sh

       

      Args to shell: C:\Users\Eduardo Avelar\AppData\Roaming\Arduino15\packages\Intel\tools\sketchUploader\1.6.2+1.0/x86/bin C:\Users\Eduardo Avelar\AppData\Local\Temp\build8008481203840338130.tmp/Blink.cpp.elf COM19

      # clupload script to invoke lsz

      COM PORT 19

      # Copyright (C) 2014 Intel Corporation

      Converted COM Port COM19 to tty port /dev/ttyS18

      #

      Sending Command String to move to download if not already in download mode

      # This library is free software; you can redistribute it and/or

      Deleting existing sketch on target

      # modify it under the terms of the GNU Lesser General Public

      # License as published by the Free Software Foundation; either

      # version 2.1 of the License, or (at your option) any later version.

      #

      # This library is distributed in the hope that it will be useful,

      # but WITHOUT ANY WARRANTY; without even the implied warranty of

      # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU

      # Lesser General Public License for more details.

      #

      # You should have received a copy of the GNU Lesser General Public

      # License along with this library; if not, write to the Free Software

      # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301  USA

      #

       

      echo "starting download script"

      echo "Args to shell:" $*

       

      # ARG 1: Path to lsz executable.

      # ARG 2: Elf File to download

      # ARG 3: COM port to use.

       

      #path contains \ need to change all to /

      path_to_exe=$1

      fixed_path=${path_to_exe//\\/\/}

       

      #COM ports are not always setup to be addressed via COM for redirect.

      #/dev/ttySx are present. Howwever, COMy -> /dev/ttySx where x = y - 1

       

      com_port_arg=$3

      com_port_id=${com_port_arg/COM/}

      echo "COM PORT" $com_port_id

      tty_port_id=/dev/ttyS$((com_port_id-1))

      echo "Converted COM Port" $com_port_arg "to tty port" $tty_port_id

       

      echo "Sending Command String to move to download if not already in download mode"

      echo "~sketch downloadEdison" > $tty_port_id

       

      #Move the existing sketch on target.

      echo "Deleting existing sketch on target"

      "$fixed_path/lsz.exe" --escape -c "mv -f /sketch/sketch.elf /sketch/sketch.elf.old" <> $tty_port_id 1>&0

       

      Transfer incomplete

      # Execute the target download command

       

      #Download the file.

      host_file_name=$2

      "$fixed_path/lsz.exe" --escape --binary --overwrite $host_file_name <> $tty_port_id 1>&0

      Sending: C:\Users\Eduardo

       

      Bytes Sent:    204   BPS:7977                        

      lsz: cannot open Avelar\AppData\Local\Temp\build8008481203840338130.tmp/Blink.cpp.elf: No such file or directory

       

      Transfer incomplete

       

      #mv the downloaded file to /sketch/sketch.elf

      Moving downloaded file to /sketch/sketch.elf on target

      target_download_name="${host_file_name##*/}"

      echo "Moving downloaded file to /sketch/sketch.elf on target"

      "$fixed_path/lsz.exe" --escape -c "mv $target_download_name /sketch/sketch.elf; chmod +x /sketch/sketch.elf" <> $tty_port_id 1>&0

       

      Transfer incomplete

      -------------------------------------------------------------------------------------------------------------

      Thats all!!

        • 1. Re: Help - Intel Edison and Arduino IDE uploading problem
          channinglin

          Did you plug both micro USB as well as the external power supply?

          • 2. Re: Help - Intel Edison and Arduino IDE uploading problem
            Intel_Alvarado

            Hi

             

            Follow channinglin suggestion. Make sure you plug both USB cables and also use an external power supply. If you still receive the error, try using different USB cables to see if this behavior persists.

            Additionally, what IDE version are you using, what image do you have installed in your board? You can check the version with configure_edison –version. In what path did you install the Arduino IDE?

             

            Sergio

            • 3. Re: Help - Intel Edison and Arduino IDE uploading problem
              Eduardo1742

              Hi all.

               

              Thanks channinglinand and Intel_Alvarado for your kindly sugestions.

               

              Yes, I'm using a 12V, 1500mA power supply in my Edison Arduino breakout board. The problem persist after change the USB cables that I previously used on my Arduino micro board.

               

              At the first time when I tried to instal everything, my Norton antivirus had identified some .exe extensions from intel path as virus, but I permited all .exe manually as not virus. I felt a bit afraid about some files that had been excluded without I see, so I uninstalled everything and reinstalled using the Intel "w_iot_2015.0.028" installer, but everything are the same as you guys can see.

               

              The Arduino file path is:  C:\Intel\arduino-1.6.5

              The image version is: 159.

              Windows version: 10

               

              If nothing help me, i will change my Antivirus software, use an windows "restoration point" before the day that I started to install Intel softwares and drivers and than try everything again.

               

              Thanks all..

              • 4. Re: Help - Intel Edison and Arduino IDE uploading problem
                Eduardo1742

                Solved.

                 

                I restarted my windows 10 laptop as default and changed my antivirus software. After this, I used the intel software and worked pretty good.

                 

                I think that the problem was with some driver that my antivirus "got for him", Now everything is working perfectly.

                 

                I hope this tip will help someone one day.

                 

                Thanks everyone.