7 Replies Latest reply on Feb 10, 2016 6:22 AM by mikec_intel

    Problem Windows 10 on NUC5i5RYH on Kingston M.2 (BSOD)

    Jojje

      Recently purchased an Intel NUC5i5RYH with a Kingston M.2 2280 120 GB (SM2280S3/120G) drive. BIOS set to UEFI boot, disabled Legacy, no Secure Boot and AHCI.

       

      The Windows 10 x64 install went fine. After some time I was getting random BSOD with errors such as Driver_IRQL_NOT_LESS_OR_EQUAL (storahci.sys), CRITICAL_PROCESS_DIES, BAD_SYSTEM_CONFIG.

       

      I ran Memtest and tried memory in another computer to confirm it was working. I replaced the NUC (replaced by warranty) - same problem. I tried re-installing Windows 10 and also trying Windows 8.1 - same problem. I also tried formatting the drive without any errors. I tried both older BIOS (249) and newer BIOS (350, 351, 352). The drive has been confirmed working by the reseller. This makes me think there is something in the NUC <-> M.2 combination causing this problem.

       

      Started searching around and it seems there are many who has problems with M.2 disks. So before I go ahead and troubleshoot further or ask the reseller to replace the drive, maybe anyone can comment if there might be any known issues that I should be aware of?

       

      Here are some detailed info from the label on the drive:

      9904689-003.A01G