6 Replies Latest reply on Feb 24, 2016 10:40 AM by mariusp66

    ethtool shows only rx_queue_0_packets/bytes counter for ixgbe driver v 4.1.5

    mariusp66

      ethtool (latest version) only shows rx_queue_0_packets/bytes queue counter even though ixgbe is loaded with default parameters and allocated 16 receive queues. All queues are getting used nevertheless as can be seen from /proc/interrupts. This is on RHEL 5.8 stock kernel 2.6.18-308 but the same is on stock 5.11 2.6.18-398.el5.
      I have tried several ixgbe versions and found out that last ixgbe version that ethtool properly displays counters for all allocated queues is 3.16.1 so perhaps this is expected in later versions - would be good to know the reason if that indeed is the case.


      Interesting also is that RX queue 0 is shared with TX queue now meaning that RSS=1 mean single queue for RX and TX and RSS=2 mean TX/RX shares queue 0 and RX queue 1 and so on. Obivously, 2.6.18 does not support multiple TX queues.

      I tried to look for an answer in all mailing lists but didn't find anything.

      Attaching an output from dmesg, ethtool, /proc/interruprs and modinfo.