2 Replies Latest reply on Jan 12, 2016 5:53 AM by TAlbrecht

    X710 Jumbo Packet doesn't work after reboot

    TAlbrecht

      We are trying to setup a new Hyper-V cluster on Dell PE730 with X710-DA4 cards.  I have the cards in NPAR+EP mode so we get 4 nics per port.  I'm trying to setup the 4 partitions as follows:

      Partition 1 = Hyper-V switch with SR-IOV in vlan 11 (it's also the native vlan on the trunk)

      Partiiton 2 = Live Migration in vlan 2 and Jumbo Packets

      Partition 3 = iSCSI in vlan 101 and Jumbo Packets

      Partition 4 = Management network in vlan 12

       

      I'm using powershell to run the config so we can easily deploy this in server core or hyper-v server 2012 R2. Switching is Cisco Nexus 3548.  iSCSI SAN is Compellent 4020. Everything is setup as per published best practices.

       

      Everything works great until we reboot!

      Jumbo frames is still set in the registry and on the driver advanced property page, but Jumbo packets don't get through.  We have to disable Jumbo Packets and then re-enable Jumbo Packets for it to work again. 

       

      Here is my PS script to do the initial setup:

      echo "########################"

      echo "#Setup VMQ and SR-IOV  #"

      echo "########################"

      $VMQ = Get-IntelNetAdapterSetting -DisplayName "Virtual Machine Queues"

      $VMQ | Set-IntelNetAdapterSetting –DisplayValue "Enabled"

      $SRIOV = Get-IntelNetAdapterSetting -DisplayName "SR-IOV"

      $SRIOV | Set-IntelNetAdapterSetting –DisplayValue "Enabled"

      $JUMBO = Get-IntelNetAdapterSetting -DisplayName "Jumbo Packet"

      $JUMBO | Set-IntelNetAdapterSetting –DisplayValue "Disabled"

      echo "########################"

      echo "#  Add VLANs to NICs   #"

      echo "########################"

      Add-IntelNetVLAN -Parent $Adapters[4,5,6,7] -VLANID 2

      set-intelnetvlan -parent $Adapters[4,5,6,7] -vlanid 2 -newvlanname "LiveM_Vlan2"

      Add-IntelNetVLAN -Parent $Adapters[8,9,10,11] -VLANID 101

      set-intelnetvlan -parent $Adapters[8,9,10,11] -vlanid 101 -newvlanname "iSCSI_Vlan101"

      Add-IntelNetVLAN -Parent $Adapters[12,13,14,15] -VLANID 12

      set-intelnetvlan -parent $Adapters[12,13,14,15] -vlanid 12 -newvlanname "MGMT_Vlan12"

      echo "########################"

      echo "#  Set Jumbo packet    #"

      echo "########################"

      Set-IntelNetVLANJumboPacket –Parent $Adapters[4,5,6,7] -VLANID 2 –DisplayValue "9014 Bytes"

      Set-IntelNetVLANJumboPacket –Parent $Adapters[8,9,10,11] -VLANID 101 –DisplayValue "9014 Bytes"

      Set-IntelNetVLANJumboPacket –Parent $Adapters[0,1,2,3,12,13,14,15] -DisplayValue "Disabled"

       

      Here is my script to fix Jumbo packets after a reboot.

       

      $Adapters = Get-IntelNetAdapter

      Set-IntelNetAdapterSetting –Name $Adapters[4].Name -DisplayName "Jumbo Packet" -DisplayValue "Disabled"

      Set-IntelNetAdapterSetting –Name $Adapters[4].Name -DisplayName "Jumbo Packet" -DisplayValue "9014 Bytes"

      Set-IntelNetAdapterSetting –Name $Adapters[5].Name -DisplayName "Jumbo Packet" -DisplayValue "Disabled"

      Set-IntelNetAdapterSetting –Name $Adapters[5].Name -DisplayName "Jumbo Packet" -DisplayValue "9014 Bytes"

      Set-IntelNetAdapterSetting –Name $Adapters[6].Name -DisplayName "Jumbo Packet" -DisplayValue "Disabled"

      Set-IntelNetAdapterSetting –Name $Adapters[6].Name -DisplayName "Jumbo Packet" -DisplayValue "9014 Bytes"

      Set-IntelNetAdapterSetting –Name $Adapters[7].Name -DisplayName "Jumbo Packet" -DisplayValue "Disabled"

      Set-IntelNetAdapterSetting –Name $Adapters[7].Name -DisplayName "Jumbo Packet" -DisplayValue "9014 Bytes"

      Set-IntelNetAdapterSetting –Name $Adapters[8].Name -DisplayName "Jumbo Packet" -DisplayValue "Disabled"

      Set-IntelNetAdapterSetting –Name $Adapters[8].Name -DisplayName "Jumbo Packet" -DisplayValue "9014 Bytes"

      Set-IntelNetAdapterSetting –Name $Adapters[9].Name -DisplayName "Jumbo Packet" -DisplayValue "Disabled"

      Set-IntelNetAdapterSetting –Name $Adapters[9].Name -DisplayName "Jumbo Packet" -DisplayValue "9014 Bytes"

      Set-IntelNetAdapterSetting –Name $Adapters[10].Name -DisplayName "Jumbo Packet" -DisplayValue "Disabled"

      Set-IntelNetAdapterSetting –Name $Adapters[10].Name -DisplayName "Jumbo Packet" -DisplayValue "9014 Bytes"

      Set-IntelNetAdapterSetting –Name $Adapters[11].Name -DisplayName "Jumbo Packet" -DisplayValue "Disabled"

      Set-IntelNetAdapterSetting –Name $Adapters[11].Name -DisplayName "Jumbo Packet" -DisplayValue "9014 Bytes"

       

      NOTE:  Set-IntelNetJumboPacket doesn't work to fix the issue.

      NOTE2:  We can't setup a failover cluster in this fashion because the CSV disks won't come online until we can reset Jumbo Packets

      NOTE 3: We also have an SR open with Dell.

      NOTE 4:  All drivers and firmware are up to date.