8 Replies Latest reply on Jan 8, 2016 4:13 PM by Galileo_BR

    Problem Ethernet communication and uploads.

    Galileo_BR

      hello, I'm having some problems with the GalileoGen2 connection to the Internet, even setting up the IP and MAC address in the program do not get communication, I am using the IDE 1.6.5 for Galileo intel. When I type the IP browser, or try to give a ping from the command prompt (cmd), do not get answer. I only have positive response when I upload other code that will post below. The second problem is how to upload. It's almost impossible to unload a few lines of code on the board. I get several errors. I also use Debian 8 in duall boot with Windows 7, and Debian is also the same problem, it is even worse because the codes that compile the IDE using Windows are at least compiled and the same code in the IDE linux 64 to cause errors.

      Among the upload failures I get, permission denied among others ..

       

       

       

      With the code below I can assign an IP in Galileo.

       

      void setup()

      { 

      system("telnetd -l /bin/sh");

      system("ifconfig enp0s20f6 192.168.1.27 netmask 255.255.255.0 up");

      }

      void loop() {

      }

       

       

      I researched about the failures uploaded program and found no solution. What did I found was that when Galileo has a sketch running the same

      does not allow in any way, receiving another program. I've tried several things, change serial port in device manager .. off, reset or restart Galileo, and none of it works.

      The only thing that solves it temporarily shut down the computer.

      Still I can barely make two uploads until some faulty process Galileo intel or IDE prevents you from downloading some code.

      I have also tried to list running processes ('top' command) through Putty in order to kill the sketch process, the more all to no avail.

      The board at this level should not have this problem I believe.

       

       

       

      I'm getting a message saying that the ethernet library claims to run on another architecture (i586 uClibc), but the code is compiled. I do not know if this can be the cause of the connection problem.

      GalileoError5.png

       

      GalileoError6.png

          trying to ping the IP assigned to Galileo.

       

       

      GalileoError7.png

       

      After Web Server upload or other code, Galileo always has IP configuration error. I can be confusing some things as the setting.

      Despite the fact the failures upload, I believe it has a way to solve.

      I am using the code below, when I see that can not ping Galileo.

       

      void setup()

      {

       

      }

      void loop()

      {

      system("ifconfig > /dev/ttyGS0");

      sleep (10);

      }

       

       

      Sorry excess written lines ..