5 Replies Latest reply on Jan 14, 2016 1:23 AM by R2DJoe

    using an FTDI device

    R2DJoe

      We have a couple of edison devices.

       

      so I've got my ftdi device plugged into the (arduino) breakout board and the switch is closest to the USB host port. I've got a fresh instance of the latest (3.10.17?) yocto image on there, and have added the `repo.opkg.net/edison` repos to `/etc/opkg/base-feeds.conf` and updated/etc but even tho `kernel-module-ftdi-sio` is installed it doesn't pick up the device. `lsusb` reports `unable to initialize libusb: -99`  and I've tried a bunch of other things to get it to work but I'm stuck now.

       

      I also tried adding `iotdk.intel.com/repos` things to `/etc/opkg/itodk.conf` as reported at various places, but a) the 1.1 repos in all the blog posts I've seen don't have any newer versions, and are out of date and b) trying the 1.5 versions of the urls insists on updating EVERY package on the device because they all have a spurious .0 appended to the package name/version ????

       

      We had no problems using the ubilinux that was on one of our edisons, but the newer one constantly reports that the (latest?) image is too large for the disk (by like 2x) so we tried Yocto and that worked other than this usb junk.

        • 1. Re: using an FTDI device
          CMata_Intel

          Hi R2DJoe,

           

          With the Arduino Expansion Board and using the command lsusb you should be having the following results:

          The switch closest to the micro USB ports

          unable to initialize libusb: -99

          The switch closest to the USB Host

          Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

          Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

          What is the output of running the command configure_edison --version and uname -a?

          Which are the specifications of the power supply you are using? If you are getting the message “unable to initialize libusb: -99” in both positions of the switch the problem could be that the power is not enough for using the USB Host. This also happens with the Breakout Board if a power supply is not used.

          Please let us know the current and voltage specifications of the power supply you are using before trying with another one. Remember that the valid range is 7V – 15V

           

          This is a thread related to what you want to accomplish, take a look at it, it may be helpful: Reading USB-Serial GPS from OTG Port

           

          Regards,

          Charlie

          • 2. Re: using an FTDI device
            mpapini

            Does this help? unable to initialize libusb: -99

             

            Don't nave an Arduino myself but on my custom board i got it when i inverter RX/TX to the ftdi ... oops.

            • 3. Re: using an FTDI device
              R2DJoe

              root@edison:~# configure_edison --version

              159

              root@edison:~# uname -a

              Linux edison 3.10.17-poky-edison+ #1 SMP PREEMPT Fri Jun 19 12:06:40 CEST 2015 i686 GNU/Linux

               

              moving the switch doesn't fix the -99 error, and I'm using the power supply that came with it.

              • 4. Re: using an FTDI device
                CMata_Intel

                Hi R2DJoe,

                 

                The Edison Module + Arduino Expansion Board do not include a power supply.

                Did you bought a development kit? Could you provide a link to the kit you are using?

                Could you test the output of the power supply? This is to verify the real voltage and current in it.

                Is this the only problem you are having with the board?

                What is the output of running dmesg | grep usb with the switch closest to the USB OTG?

                 

                Regards,

                Charlie

                • 5. Re: using an FTDI device
                  R2DJoe

                  the power supply is 12V 4A

                   

                  the -99 appeared whcihever way the switch was left

                   

                  we ended up figuring out how to flash ubilinux so this topic is defunct