7 Replies Latest reply on Mar 7, 2016 10:48 AM by EstebanC_Intel

    Intel NUC 5i5RYK does not recognize rear usb ports

    kramoniker

      Hi -

       

      I recently purchased a new NUC5i5RYK and updated the BIOS to v352.  It seems the rear USB ports no longer recognize any devices.  I have attempted to connect a usb flash drive (PQI), Logitech Keyboard / Mouse Combo (K400), and a pioneer external bluray drive all without success.  The front connections do recognize and power these same devices.

       

      I looked in the visual BIOS screen and was able to confirm the 4GB device is only recognized when connected to the front ports.

      I have tried resetting the defaults in the BIOS as well as downgrading to v350 but neither option seems to help.

       

      Outside of this USB port issue, everything else seems to work as expected.  I am running windows 10 - upgraded from Windows 7 in place - and I have successfully installed all the intel provided drivers, many manually due to issues with the Intel driver update utility.

       

      I am sure the ports worked when I first powered on the device pre-BIOS update, and probably immediately after when I installed windows 7 from the external pioneer bluray drive.  I'm not sure where in the initial setup they stopped working. 

       

      Any thoughts?

       

      kramoniker