3 Replies Latest reply on Jan 7, 2016 9:20 AM by allan_intel

    Issue upgrading to Windows 10 with ICH10R chipset.  RAID array and BD drive disappear.  Strange fix.

    PSUHammer

      I recently upgraded from Windows 7 to Windows 10.  MS scan said everything should go fine, and it did, except the default Windows 10 Intel drivers for Rapid Storage cause my Blu Ray drive and mirrored RAID array to disappear.

       

      I have an ASUS Rampage Formula III motherboard with an ICH10R Intel chipset.  It also has a Marvell SATA6 controller.

       

      Drive layout is:

      1 x Samsung EVO850 SSD as primary OS drive on Marvell controller

      2 x WD 1 TB Black drives, mirrored array on Intel controller

      1 x LG Blu Ray disk drive

       

      After the upgrade, major freeze problems and the Western Digital array and cd drive are not in Device Manager.  Both show up in BIOS.  Both show up if I restore Windows 7.  I tried both Intel Rapid Storage versions available for Windows 10 with no success:  14.6 and 14.8.  Actually the software installs successfully, but the drives are gone on reboot.

       

      One thing I tried after reading online was to use an older "iaStorA.sys" and "iaStorF.sys" file from an older version of Rapid Storage (v13.6).  After manually copying over those to files to c:\windows\system32\drivers, my drives appeared again on reboot and all appears well.

       

      WTF?

       

      Is Intel going to fix this?  This is a board with an i7 processor that does NOT need upgraded.  Why the lack of backwards compatibility with a still relevant board?