7 Replies Latest reply on Jan 10, 2016 9:15 PM by Deeznuts

    GALILEO IS A BIG DISSAPOINTMENT, CANT EVEN CONNECT!

    Deeznuts

      Im sorry,  but i have posted 5 times, bought books, and read articles on articles about galileo and cant even get the light to blink because this chunk of nothing cant even get recognized by my Windows 7 laptop, and there is no solution to it!

        I have tried everything! I have read all these various post from the same people who have the same problem, nothing has worked. Im not just hurt by the fact that i have wasted at least 80 man hours trying to get a darn light to blink, but i have lost my love for the Intel Corporation! This is the greatest fail ever, getting people to sign up for this hopeless dream you gave avid makers! Im never buying an Intel product again, the Intel era is obviously over, you dont know what your doing anymore!

       

       

      - A guy done with lying tech companies

        • 1. Re: GALILEO IS A BIG DISSAPOINTMENT, CANT EVEN CONNECT!
          BenKissBox

          Hello Deeznuts,

           

          I don't really understand your position when I see all your messages against the Galileo

          But before I continue : I do not work for Intel, I have no shares from Intel, I get no money from them, I paid my Galileo (read : they were not offered to me)... so what I will say here is what I really think, not something "sponsored by Intel"

           

          If I remember well, Intel has produced something like 20.000 or 30.000 Galileo (I remember their plan was to provide many of them to technical schools). The Galileo is recognized by Arduino community, it is used by probably one or two thousands people (maybe more), it is sold by Digikey, Mouser, etc...

          Do you really think that Intel would take the risk to make something which does not work at all or is a complete nightmare to use, with a lot fo negative feedbacks from all these users and sellers? The Galileo is far from being perfect (even if Gen 2 corrected some flwas of Gen 1), but saying that it can not be trusted is absolutely wrong. I am using them everyday since years and I can tell they work, and they work perfectly.

           

          There is a common proverb in programming world saying that the problem is often located between the keyboard and the chair

           

          The communication between the Galileo and the PC is simply a USB-serial port adapter. There is nothing magical with that. I have used tens of Galileo Gen 1 and Gen 2, on Linux, Windows and Mac. I never, never got a problem. Did you check your Galileo on another PC? Did you check the USB status within the Device Manager in Control Panel (do you see an unknown device with an interrogation mark? or no device at all?)

           

          Before saying that it does not work, you have to investigate, emit hypothesis, validate them, etc.... Maybe you will discover simply that your Galileo is broken. That happens. There is something called the warranty which has created to handle these cases.

           

          Shouting and screaming about a non-fonctionning device is never the best way to correct a problem, but it's the best way to make sure that nobody will want to help you finding the problem...

          You have opened three discussions in the community for the same problem but you never described what happens on your computer, you just say "it does not work and I hate Arduino and Galileo"! How do you want a community member to help you if you act like that?

           

          Let me give you anyway a link to help you : https://learn.sparkfun.com/tutorials/galileo-getting-started-guide

           

          Once again, I have nothing to see with Intel, but I can not admit that somebody keeps saying that Galileo is a piece of sh*t without providing any technical description of the problem he has.

          • 2. Re: GALILEO IS A BIG DISSAPOINTMENT, CANT EVEN CONNECT!
            FGT

            I'm lost...

             

            Maybe all your different posts in different threads...

             

            "I have read all these various post from the same people who have the same problem, nothing has worked."

            Strange... I either finally always get things working or find a technical reason why it doesn't.

             

            If you have a specific problem (e.g. "cant even get recognized by my Windows 7 laptop") and want help, please follow a single thread, maybe one of your own until you get to a solution, or maybe we find some/another bug to report.

             

            If not, I think we are done.

             

            Fernando.

            • 3. Re: GALILEO IS A BIG DISSAPOINTMENT, CANT EVEN CONNECT!
              BenKissBox

              FGT a écrit:

               

              If not, I think we are done.

               

              I think we share the same point of view about that

              • 4. Re: GALILEO IS A BIG DISSAPOINTMENT, CANT EVEN CONNECT!
                DiegoV_Intel

                Hello Deeznuts,

                 

                I understand your frustration, and I'll try to help you using your Galileo board. I've read all your threads and I've seen that you have received suggestions from other users. In order to keep the order and follow a straight line to find a solution, and to avoid confusions between the threads, I'll help you on this thread so please keep posting your updates on this thread only so we can have all the information in one place. That way would be easy to resolve the issue.

                 

                Firstly, I've read that you were able to blink the on board LED using the Eclipse IDE. Do you have any issues with the Eclipse IDE right now?

                 

                Secondly, the main issue that I've seen in your posts is that you are not able to use the Arduino IDE with Galileo. Are you still unable to program the Galileo using the Arduino IDE?

                 

                The following are the stuff you need in order to use your board, so first make sure you have all of them:

                • The Galileo board has one USB Client port which is used to upload the Arduino sketches. Make sure you have a micro USB cable that works correctly.
                • There is a Serial port used to access the internal Galileo's console. Accessing the console will help you to program the board, and to know the current status of the board. This Serial port is next to the Ethernet jack. You will need a proper cable to access the Galileo using this interface. Check the following document to know which cable is the one that you need: Console Serial Cables for Boards and Kits
                • The Galileo has a small Yocto image onboard that allows using the board with limited capabilities. There is a bigger Yocto image that can be downloaded to expand the board's capabilities. This complete Yocto image can be downloaded from the following link: http://downloadmirror.intel.com/24355/eng/SDCard.1.0.4.tar.bz2.
                • The complete Yocto image has to be decompressed in a SD card to be used. However, the Arduino IDE can be used without the complete image, so let's try first to use the board without the complete Yocto image (without the SD card).
                • Regarding the Arduino IDE, there are a lot of versions that can be downloaded from the Arduino site; these versions are labeled 1.6.x; however I recommend you to download the version 1.6.0 from the following link: http://downloadmirror.intel.com/24783/eng/IntelArduino-1.6.0-Windows.7z. It is not the latest one, but it is the most stable version to work with Galileo, so make sure you are using this one.
                • You will need a 12V power supply unit to power the board.
                • That's all the hardware you need. Now you will need to install the drivers and update the Galileo's firmware. This can be done through the Firmware Updater Tool which is a software used to update the firmware version. You can download the Firmware Updater Tool from the following site: Download Intel® Galileo Firmware and Drivers 1.0.4
                • To install the drivers for Galileo check the following guide: IoT - Installing drivers and updating firmware for Arduino on a system with Windows* | Intel® Developer Zone. It will guide you through the process of installing the driver and updating the firmware.
                • The FTDI cable used to access the Galileo's console requires a driver too. It can be downloaded from the following site: Virtual COM Port Drivers

                 

                Once you have installed the drivers for the FTDI and for Galileo, then you should see the COM ports associated to the board in the Device Manager when both cables - USB and FTDI - are plugged.

                 

                Confirm if you have followed all the steps above. In case you have any issue during the process, post screenshots showing the error, and post a screenshot of the Device Manager to check what the status of the COM ports is.

                 

                Regards,

                Diego.

                • 5. Re: GALILEO IS A BIG DISSAPOINTMENT, CANT EVEN CONNECT!
                  Deeznuts

                  DiegoV_Intel @FGT @BenKissBox

                   

                     I figured it all out, I want to leave this subject with saying that I just feel that Intel has yet to do enough with fulfilling its mission of the Intel Galileo. If it wasn't  for my unusually persistent, hard-headed, and determined nature, Intel(and maybe even Arduino) would of lost me and made the world a darker place, all because a guy wanted to l;earn something so badly but almost couldn't because he nearly gave in to the complication of connecting the device to his laptop!

                     BenKissBox is trying to make it seem like I had this anomalous case going on, but there are several other threads related to my issue, with other users obviously frustrated with the same matter. And sparkfun.com even dedicated an article to the subject matter!

                     All I am saying is, is that hopefully there is some type of body that is out there that is making sure the Intel Galileo mission can be met, and that complications can be reduced.

                     Intel asked me what will I make? I asked myself that question deeply, and became confident and willing to do it. I then blew 40 man hours trying to connect my Galileo to my PC.

                  That's not cool.

                     If its not my dreams and aspirations, that can be blown out the window with your complications, you are to care about, please care about the kids, please care about the future that may benefit from the labor invested into this device.

                   

                  - Iam Pyre

                  • 6. Re: GALILEO IS A BIG DISSAPOINTMENT, CANT EVEN CONNECT!
                    BenKissBox

                    Let me answer you on one point, Deeznuts (in case you will read the forum again)

                     

                    I did not try to make it appear as an anomaly. I tried to make you understand that you may have a problem with a faulty board. The problem is that you clearly do not want to listen explanations, you just keep complaining about the issues. Did you only try to connect your Galileo to another PC as I recommended?

                    If there are other threads related to your issue, then why did you start new threads? You should have explained the problem in those threads.

                     

                    A good thing would have been to give us the link to the sparkfun article, and also to the threads speaking of your problem.

                     

                    Let me tell you a last thing: I work in hardware and software development for embedded systems since 25 years. If I had thrown everything away like you did everytime I lost 40 hours to investigate on a board problem, the lab where I work would have been devastated hundreds of time...

                    • 7. Re: GALILEO IS A BIG DISSAPOINTMENT, CANT EVEN CONNECT!
                      Deeznuts

                      You know, this was an experience for me to grow through. Yeah, i got up here and did a lot of nagging(not completley wrong) but i made it through the first test and i would like to thank the community for sticking with me.