3 Replies Latest reply on Jan 8, 2016 5:48 PM by EstebanC_Intel

    Brand new NUC5i5RYH won't power up. DOA?

    BangDingOw

      I installed memory and SSD, plugged it in, and hit the power switch. Nothing. No lights. No sound. No smell. No heat. Nothing.

       

      I removed the memory and the SSD and plugged it in again. The same. Nothing. Tested the outlet (it worked).

       

      Did I just buy a $350 paper weight?

        • 1. Re: Brand new NUC5i5RYH won't power up. DOA?
          EstebanC_Intel

          Hello, BangDingOw:

           

          Thank you for contacting the Intel® Communities.

           

          I would like to provide you with some steps in order to troubleshoot this:

           

          1. Test the system without RAM, you should receive 3 blinks in the power button, no video will be present.

          2. Test your RAM modules separately on each DIMM slot.

          3. Are you able to access the BIOS? If not, please perform a BIOS recovery by following the instructions here: BIOS Update Instructions for Boards and Kits

          4. Also check that all the connections are properly set. (HDMI, power adapter, RAM, SSD, etc.

          5. Test the system without any additional components, if it works, add one component at a time in order to check if one of them is the problem.

          6. Test a different power adapter if doable

          7. Test the system with a different HDMI or DP cable.

           

          Also, please make sure you are using compatible RAM in your system: DDR3L-1333/1600 1.35V SO-DIMM

           

          I look forward to your reply and outcome.

           

          Regards,

          Esteban C

          • 2. Re: Brand new NUC5i5RYH won't power up. DOA?
            BangDingOw
            Hi,

             

             

            Would the power button light go on if nothing but the power supply was connected (no RAM/SSD/etc)? With nothing installed or connected, (except for the PS of course), the power light doesn't go on, or blink or anything.

            1. With no RAM in, the power button light doesn't go on.
            2. Tried with one module in (tested both modules) and still no light goes on.
            3. Can't get that far
            4. N/A
            5. N/A
            6. I only have the one power supply

            7. I can't get past the first issue. No power to system.

            • 3. Re: Brand new NUC5i5RYH won't power up. DOA?
              EstebanC_Intel

              Hello, BangDingOw:

               

              My recommendation on this would be to contact the place of purchase to get a replacement of the unit (if still within the first 30 days after the date of purchase, if not, contact Intel Customer Support). Contact Support

               

              If you require any further information, do not hesitate to contact us back.

               

              Regards,

              Esteban C