1 2 3 Previous Next 35 Replies Latest reply on Nov 23, 2016 9:08 AM by cvare

    NUC5PPYH SD card problem

    rockit

      Having set NUC5PPYH today... Everything went smooth (including monitor works fine via noname HDMI-to-DVI cable bought at about $2.5 at Aliexpress) but the SD-card slot. It's stated in Device Manager (Win 10 Pro) as working normally. Also, I've tested the SD card thru external USB Kingston card reader on another NUC (5i3RYH) I have at hands, it' clearly seen, readable and writable. But, when inserted in 5PPYH' card slot it's not seen in Windows Explorer at all Can anybody give an advise on how to solve this problem?

        • 1. Re: NUC5PPYH SD card problem
          rockit

          Just looked more thoroughly at the info supplied for the card slot in its "Properties" in device manager. Under "events", there is "device not started". I removed the card slot from the system, then rebooted to re-install driver but it has no effect

          • 2. Re: NUC5PPYH SD card problem
            rockit

            Tried to keep experimentizing on the sd card slot behavior... By changing some parameters in (Windows 10 Pro) System>Storage, I got the situation when the card inserted in slot is visible. But it goes for a very short time, then card slot disappears from Windows Explorer. Then it (by hard-to-understand reasons) "appears" again, and so on... Finally, I got BSOD with "driver unloaded without cancelling pending operations (Sdstor.sys)" message...

            ...here, in Russia, we have now long holidays till January, 11. And I do highly appreciate that people at Intel were so polite to provide me possibility to spend enough time trying to solve this small problem with f*****g SD card slot instead of getting serious alcohol intoxication

            • 3. Re: NUC5PPYH SD card problem
              ivanu_intel

              Hello rockit,

               

              Thank you for joining the Intel communities.

               

              What version of Windows are you using?

               

              Please be aware that the SD card reader is not supported in Microsoft* Windows* 7

               

              You can see it at:

              http://downloadmirror.intel.com/24956/eng/NUC5CPYB_NUC5PPYB_TechProdSpec06.pdf

              Page 43

               

              Regards,

               

              Ivan

              • 4. Re: NUC5PPYH SD card problem
                rockit

                Hi, Ivan

                Thank you for the reply. I use Windows 10 Pro. In fact, the SD slot on my NUC behaves in a very strange way: it may be recognized if SD card is put in the slot before NUC itself is powered on. But, if I try to perform any operation with the card (i.e. copying files to it), it terminates within half of minute or so and the card slot itself disappears from Windows Explorer. And I can see very uncommon (for me) information on the device in Device Manager. First, it's stated that the device called "Intel SD Host Controller" works normally. On the other hand, I see the message that device was not started in its properties, under "Events" tab

                P.S. Please take into account that I have Russian version of Windows, so the translation of Windows messages may be not quite correct...

                • 5. Re: NUC5PPYH SD card problem
                  Amherst

                  Hello Ivan.

                  What is the difference between the NUC5PPYH and NUC5PPYB?

                   

                  The link you posted is the tech specs for the latter and this thread is referring to the NUC5PPYH.

                  Thanks.

                  • 6. Re: NUC5PPYH SD card problem
                    rockit

                    Although I'm not Ivan... NUC5PPYB is motherboard only, NUC5PPYH is a complete product, mini PC without RAM module and internal SATA disk that a customer needs to buy to complete the system

                    • 7. Re: NUC5PPYH SD card problem
                      Amherst

                      Thanks for the info rockit

                      • 8. Re: NUC5PPYH SD card problem
                        ivanu_intel

                        What rockit said is correct the NUC5PPYB is the motherboard and NUC5PPYH is the complete kit.

                         

                        rockit do you have the latest BIOS version? If not, you can try with a BIOS update, please download the latest version at the following link:

                        Download BIOS Update [PYBSWCEL.86A]

                         

                        Please follow the steps for BIOS Update Instructions for Intel® NUC here:

                        F7 BIOS Update Instructions for Intel® NUC

                        • 9. Re: NUC5PPYH SD card problem
                          rockit

                          No, I have version 044 installed. Thanks for the suggestion, Ivan, I'll give a try on weekend and report here about results

                          • 10. Re: NUC5PPYH SD card problem
                            ivanu_intel

                            Thanks I will appreciate if you can let me know

                            • 11. Re: NUC5PPYH SD card problem
                              slikvik

                              I'm also having the exact same problem with the same model. SD card just wont show up. Sometimes Windows makes the detected hardware sound and then a second time as if it's losing connection. Doesn't show up as a drive in between. One of the SD Card items in Device Manager shows and exclamation mark, remove that, reboot, still doesn't work. This SD card slot is imperative for me so please look into this!

                              Using the bundled Windows 10 Home. Running BIOS 48 already.

                              • 12. Re: NUC5PPYH SD card problem
                                rockit

                                Thank you for information. This means that there is no sense for me to upgrade BIOS to 048 version...

                                • 13. Re: NUC5PPYH SD card problem
                                  slikvik

                                  Any news on this? I got my SD card to show up last night be leaving it in (undetected) and then rebooting the NUC. However when trying to write to it, it would fail after 10 minutes. I can use the exact same SD card in a USB card reader in the the same NUC and it reads fine.

                                   

                                  If it's a driver issue, please tell us what drivers we need to install. If it's a hardware fault (which strangely me and @rockit are both experiencing) then we need to be sure as I really don't want to have to return a whole PC that is used daily because the SD card readers on these NUCs are problematic.

                                   

                                  Thanks

                                  • 14. Re: NUC5PPYH SD card problem
                                    rockit

                                    As to the situation you described, I used to have the same one: when NUC was started with the card inserted in the slot the drive was recognized by OS and showed up in Explorer. But when I tried and copy some files to the card the operation was aborted short after its beginning and drive disappeared from Explorer

                                    1 2 3 Previous Next