7 Replies Latest reply on Jan 22, 2016 9:45 AM by allan_intel

    Is this a faulty Processor? I7 4790k

    TimMavis

      Greeting everyone,

      First off I wish you have a happy new year. Today, I write this discussion to get some help.

      My PC Specs:

      • Intel Core I7 4790K processor
      • Asus Z97-A motherboard
      • 16Gb DDR3 Kingston HyperX Fury 1866Mhz
      • EVGA 850w 80+ gold PSU
      • EVGA GTX 950 FTW Graphic Card
      • 120Gb PNY SSD
      • 1TB WD Black HDD
      • Everything is brand new and compatible.

      Three months ago, I bought a brand new Intel Core I7 4790k Processor on Amazon. It was the greatest processor I ever had in my life. Unfortunately, for last couple weeks ago, it stopped working. When I hit the power button, CPU cooler fan and case fans spin well. However, there was nothing happen on monitor screen. No video signal. No Beep POST as well.I opened the case and saw red CPU LED on the motherboard that according in the Asus Z97-A/USB 3.1 motherboard manual said "The POST state LEDs provide the status of these key components during POST (Power-On-Self Test): CPU, memory modules, VGA card, and hard disk drives. If an error is found, the critical component's LED stay lit up until the problem is solved." (page 1-36). I will describe the problem from beginning. I was playing video game on my computer and then suddenly, the computer turned itself off. I couldn't turn it on later on. I thought it was power supply (EVGA 500w 80plus bronze) problem so I ordered another brand new power supply EVGA 850w 80 plus Gold on Amazon. After plugging the new PSU, the issue was still existing. Searching solutions on some PC technical forums on internet, I came with another idea: Faulty Motherboard. My motherboard was brand new Asus Z97-A. I also purchased it on Amazon. It was compatible with 4th gen Intel processor such as the I7 4790k i had and this combo mobo/cpu worked perfectly for 3 months. Last night i received another brand new Asus Z97 A motherboard to replace the previous motherboard. Luck wasn't on my side, the red CPU LED was still there on new Motherboard. I was out of idea and I decided to bring my PC to Computer repairing stores to get fix by the technician there. They did what I already done before. They suggested me to contact Intel to get a replacement because my warranty is covered until 2018. I honestly don't really want to send it back until there is not any way left. The processor has no sign of damage or burn marks so It might be something wrong inside of it. Can you tell me that if this is a faulty processor?