4 Replies Latest reply on Jan 14, 2016 1:25 PM by lohikdoyon

    X540-T2 problem since latest Windows Server 2012 R2 Update

    RobertSal

      I was updating a base server with the X540T2 card, and noticed that I lost remote access as the updates started to install. I went to teh physical server, and found that the NIC was no longer connected to the Internet. I allowed the updates to complete, and then on reboot, the NIC issue was still there.

       

      The 2 ports of the X540-T2 (connected as just plain 10GBase-T to a X712 netgear hub), were listed as FCoE device in device manager - with a yellow caution triangle. I tried to reinstall the driver (downloaded the x64 .exe driver install from Intel website), and this still occurred.

       

      I them manually selected the X540T2 driver from the list of available drivers, and the device came up, but there was still an error. I then used a driver from Sep2015 (manually selected), but when trying to set the IP address of the main port, I would get a preferred IP address (that I entered in teh static settings), and a tentative IP address (- that is not in my segment. The Tentative address would not go away.

       

      I then ran out of time, and simply enabled the onboard 1Gbit ports, and configured those for Network, and HyperV, just so the server would not be down.

       

      Any idea what is happening.

       

      Other servers share the same hub with no problems (I did not try changing ports on the hub, but could do that - as I have a couple of free ports). Is there a clean way to completely uninstall all the drivers etc and reinstall?

        • 1. Re: X540-T2 problem since latest Windows Server 2012 R2 Update
          Sandy_Intel

          Hi RobertSal,

           

          Thank you for contacting Intel.

           

          You can find steps to uninstall network software and driver on the website below:

          Unable to Uninstall Intel® Network Connections, Intel® PROSet, or...

           

          Hope this helps.

           

          Sincerely,

           

          Sandy

          • 2. Re: X540-T2 problem since latest Windows Server 2012 R2 Update
            RobertSal

            Thanks - I in the end did not need to do this. Once I was running with the 1Gb Ethernet connections, I changed the IP address to be another one in the segment (not the original server's IP address). I then re-enabled the x540 connections - one at a time, and initially set the IP address to DHCP. This worked. Then I set it to static and this worked as well. I used the driver from Sep 2015. I did the same for the second X540 connections - and set up the hyper V connection to it - again worked OK.

             

            Windows Update then asked me to update the Driver - Recommended update, and there were 2 FCoE optional updates - I selected Hide updates to eliminate them, and hopefully the next update will not exhibit the same problem.

             

            I updated a server with on motherboard 10Gbit Ethernet today as well - no problems

            • 3. Re: X540-T2 problem since latest Windows Server 2012 R2 Update
              lohikdoyon

              Hi All,

               

              I have the same issue as described. Server : Dell r720 with 1X Intel X540-T2 + the onboard  x540/i350 combo. The server is an Hyper-V 2012 R2 Server (full Windows Datacenter setup)

              After the Windows update I lost all connections of the two 10gig ports of my onboard x540/i350. the two i350 gig ports were still running OK. the PCI-E x540-t2 was still running OK also.

               

              And I noticed as described, two FCoE device now in the DM with exclamation mark over them.... I had to do a manual uninstall of them from the DM + a research of new device then I got back my two 10Gig port as NIC not FCoE...... What a flaw from MS + Intel..... Worst is that now the setup of IP addr is a pain. Not to mentionned that I used NIC Teaming with Windows and ajustement of RSS for adapters prots to have CPU affiinity etc. all has to be redone over a running Hyper-V server.... I was very, very angry.......

              Anyway now it's back to running state.

               

              BUT

               

              After trying to run a normal driver package setup from Intel for the NIC (PROWinx64_V.20.4.1) on that server. I got a cool msg :

              intelsetup.PNG

               

              I don't have FCoE on that server, in fact I don't have nay FCoE at all in all my stuff.

               

              I gess it is related hum !?!?!?

               

              Installing the mentionned KB is ridiculous as this is a superseeded KB since more then 2 years now.....

               

              Please someone help me to put back this server to it's normal state.

               

              Note, before this episode with Windows update and FCoE device/lost NIC a previous ProWinx64 from Intel was executed with no error from the same server.....

              • 4. Re: X540-T2 problem since latest Windows Server 2012 R2 Update
                lohikdoyon

                To all,

                 

                anybody has a clue ?

                Please having the drivers setup failling is not a possibility for the long run.

                 

                Thanks in advance