2 Replies Latest reply on Jan 5, 2016 12:31 PM by ivanu_intel

    new NUC5i7RYH does not power up

    Thum1

      No light of any color behind the power button when the power is plugged in - wondering if the unit is defective?

      added G.Skill Ripsaws F3-1866C10D-16GRSL and Samsung 850 EVO 250GB M.2

      Any help/suggestions would be appreciated.

      Thanks

        • 1. Re: new NUC5i7RYH does not power up
          moreadon

          Also have the same problem with a NUC5CPYH model out of the box. Only light that is on is the green one bihind the sd card slot (can see it when case in open).

          • 2. Re: new NUC5i7RYH does not power up
            ivanu_intel

            Hi,

             

            Thank you for joining the Intel communities.

             

            Did these units work and then failed or they never worked?

             

            If your unit worked before, under what circumstances the unit stopped working, new hardware/software was added, any update etc?

             

            If you don’t get any light or power at all, you could try with different power adapter?

             

            Do you get any fan activity?

             

            If there is no fan activity and if the computer is not beeping and the Diagnostic LEDs and caps/num/scroll lock LEDs are not flashing or lit, unplug all connections and remove all media communication devices (external monitors); reconnect one at a time and check if the unit functions.

             

             

            Regards,

             

            Ivan