2 Replies Latest reply on Dec 31, 2015 2:52 PM by Silly_goose

    I can't access BIOS on DH67BL: keyboard unresponsive?

    Silly_goose

      I'm trying to access BIOS on DH67BL, using a Microsoft Natural Ergonomic Keyboard 4000 in a USB 2 port. Hitting F2 for Setup does nothing, neither do F7 or F10 (which are supposed to be BIOS Setup, BIOS update and Boot Menu, respectively). I'm sure I have been able to access BIOS before on this motherboard; but I'm not sure if I have been able to access it with this keyboard. I have no other keyboard for testing. Once the operating system loads the keyboard is fully functional again.

       

      I have tried setting the jumper for BIOS maintenance mode: that opens up the maintenance mode, but there's no keyboard functionality there either so I can't make any changes or even view the settings. I also have tried removing and replacing the battery to restore default settings in case I have inadvertently previously changed something in BIOS: the clock was reset, but apart from that no difference (well, the computer didn't boot up properly then - fans turned but no signal to the screen - after that. Until I reset the jumper for BIOS maintenance mode and then back to normal, and now it boots up tnormally, but no difference where I was trying to make one.)

       

      I'm thinking it could be an issue with the keyboard, but I can't test that now. What else could it be? How to fix or get around this? For now, I just want to set my new SSD as the first boot option, but in the end I really should be able to access BIOS anyway.