8 Replies Latest reply on Feb 19, 2016 2:44 PM by mikec_intel

    UEFI dual boot installation corrupts on NUC5i5RYK

    Shelf_June

      I've reproduced the issue two times, the steps are as following:

       

      1. disable the legacy bios mode.

      2. install Windows 10 64-bit

      3. install Ubuntu 15.10 or Debian 9 stretch di alpha4 (testing build)

      4. reboot and select Windows 10

      5. reboot in Windows 10

       

      The NUC got soft bricked without able to escape following dead situation.

       

      >>Checking Media Presence....

      >>Media Present....

      >>Start PXE over IPv6

       

      (a few minute later) A bootable device has not been detected.

       

       

      My BIOS had already been upgraded to latest version 2015.1130, so far I can do nothing but restore the BIOS to default setting. But even after that the box direct goes for PXE networking boot media and fails by 'PXE-E53: No boot filename recevied'. Obviously, the SSD content is trashed.

        • 1. Re: UEFI dual boot installation corrupts on NUC5i5RYK
          mikec_intel

          Hi Shelf_June,

           

          I suggest you to verify which the current BIOS is in your NUC. Use BIOS version 0350 or newer. Then, get into the BIOS and enable UEFI and Legacy boot on Boot tab. Go to devices tab and enable USB Legacy.

          Drivers & Software

           

          Reinstall Windows® 10:
          Restart the NUC and keep tapping F10, select UEFI:USB: name or model of Windows® 10 USB bootable drive.

           

          Then, create a partition for Ubuntu using Windows® 10 Disk Management.

           

          Finally, follow the steps from http://www.linuxandubuntu.com/

          Dual-Boot Ubuntu 15.04/14.10 And Windows 10/8.1/8: Step By Step Tutorial With Screenshots - LinuxAndUbuntu

           

          Regards,
          Mike C

          • 2. Re: UEFI dual boot installation corrupts on NUC5i5RYK
            Shelf_June

            Mike,

             

            Thanks for your answer. But I wasn't going to search workaround here because I'd found it myself. I'm just bringing up a repeatable defect under a common scenarios. i.e. UEFI ONLY with dual boot. Legacy BIOS mode is phasing out, disabling it totally isn't a bad ideal, right? Let's call Intel's attention for its production quality. In this forum, I have seen a couple of cases of bricking NUC for various BIOS reasons.

             

            Regards

            Shelf

            • 3. Re: UEFI dual boot installation corrupts on NUC5i5RYK
              Sunspark

              It is possible to have a UEFI only dual-boot with Win 7 and Linux on the NUC. I have it on mine which is on the 246 bios.

               

              Steps are:

              -Legacy mode on in the BIOS

              -Install Windows 7 first, leave empty unpartitioned space for Linux.

              -Install Linux second into the empty unpartitioned space.

               

              At this point you have a UEFI GRUB bootloader. You can now turn legacy mode off and Win 7 will boot in UEFI mode via the GRUB bootloader.

               

              Note that if you mess around with your partitions after this, you will have to type in the mapping by hand in GRUB, I`ve done it. If you know what to type it`s fine but the first time can be alarming, so it is easier to know what partition sizes you want ahead of time.

              • 4. Re: UEFI dual boot installation corrupts on NUC5i5RYK
                Shelf_June

                Your approach works until you want to re-install the second OS, i.e. Linux. I've proved it would still destroy your entire SSD content if you ever switch the legacy mode off and then on before the reinstallation. So my lesson is never playing with that legacy option before Intel gives a fix.

                • 5. Re: UEFI dual boot installation corrupts on NUC5i5RYK
                  Sunspark

                  Shelf_June What? No. You don't have to change legacy on and off the second time around. Leave it off after the first time. Just delete the Linux partition (better if you delete it from within the Linux partition tool, but you can do it from Windows too since the assumption is you'll be booting from a flash drive anyway). Legacy mode is only required the first time you are setting up the brand new drive and installing Windows 7 on it first, before Linux or anything else. After GRUB is installed in the bootloader and everything is in UEFI, you are good to go with deleting partitions. Tip: If you use linux heavily, set /home up as a separate partition.

                  • 6. Re: UEFI dual boot installation corrupts on NUC5i5RYK
                    Cesar Badilla

                    Hello Shelf_June,

                     

                    Please follow Sunspark's  recommendations and let us know of the outcome.

                     

                    Additionally, take into consideration the fact Dual-boot  installation on Intel®NUC5i5RYK  is not developed by Intel. When making a dual-boot installation, it is necessary to take into consideration any errors could be the cause of the failed boot specially on Linux* GRUB Boot-loader.

                     

                    Regards,

                    Caesar B_Intel.

                    *Other names and brands may be claimed as the property of others.

                    • 7. Re: UEFI dual boot installation corrupts on NUC5i5RYK
                      venik212

                      This might not be the right place to ask about it, but I have a NUC5i5RYK that will not boot.  I installed on it Linux/Mint 17.3/Cinnnamon 2.8.6, and it worked fine until it was bricked after suspension (many posts here on that sad topic).  I revived it by dis-assembly, pulling the cmos battery connector off, and re-assembly.   Then I upgraded the BIOS to V. 353, and for a few days it worked OK.  But now it behaves in an even stranger way: the blue power LED is on, but the TV screen that it is connected to (via HDMI) says: not connected... check the wires, etc.  I tried booting it from a USB drive that will boot other computers, but it ignored it.  I tried re-installing the latest version (V. 354) of the BIOS (long press on power button, F7), but that did not cure it.

                      I am at a loss.  I bought 16 gb of RAM (from Crucial) and a 250 gb Samsung SSD for it, which will probably be lost if I returned the NUC to Intel.

                      Could anyone tell me how to get it to boot from the USB?  If I managed to do that, I could re-install Mint on it, but it refuses to acknowledge the USB, even though the boot order in the BIOS tells it to first boot from a USB drive.

                      Any suggestion would be appreciated.

                      • 8. Re: UEFI dual boot installation corrupts on NUC5i5RYK
                        mikec_intel

                        Hi venik212,

                         

                        I suggest you to get into the BIOS, reset settings with F9 then, save changes with F10. Try to boot from the USB; if problem continues go to BIOS>Devices>USB and Disable xHCI and try again.

                         

                        Regards,
                        Mike C