5 Replies Latest reply on Jan 5, 2016 11:52 AM by EstebanC_Intel

    i7-4712HQ does not reach 100% of the clock speed when "PCI Lock" is Unchecked in Advanced Boot settings

    Kastytis_D

      Hi Guys,

       

      Ran into quite a strange problem, so thought I'd give this forum a try. Tried discussing it on the Windows community forums but they were having none of it.

       

      I've noticed that the machine felt sluggish over the past month or so, but never gave it much though. Today, for some reason I opened up the Task Manager, and noticed that no matter how much load the CPU is getting, the speed does not go over 2.28GHz (Standard clock speed is 2.3GHz). Now, at first I thought it could be the power settings, since I have managed to throttle the processor speed previously by reducing it to 95%. After some playing around, I ruled out the power settings, since the system does respond to them if you cut the maximum power state, the processor speed cuts down too. When set at 100%, it does not go over 2.28GHz. This means, since its a TurboBoost pocessor, that because it doesn't reach its full capacity, it does not go into TurboBoost.

       

      I have updated the drivers, and the BIOS from the manufacturers website. The only way to resolve this issue, is by ticking the "PCI Lock" box in advanced boot options in msconfig. When the box is ticked, the computer restarts and the processor works correctly, boosting up to 3.3GHz. The only issue with that is, once the box is ticked, issues arise with other devices, for example, the network card is not recognised at all. Un-tick the box, restart, and the network card functions as it should, but the processor is throttled.

       

      I dont know if this could be affecting the issue in any way, but the secondary HDD fails to spin down according to the power settings. It is supposed to stop after 1 minute, but despite having no activity (in resource monitor, or audible reads/writes) it keeps spinning.

       

      The specs are:

       

      Dell M3800

      Windows 10 Pro

      CPU i7-4712HQ 2.3GHz (Up to 3.3GHz)

      16GB RAM

      512 Samsung SSD (With OS)

      1TB Secondary

       

      I am not sure when did the issue begin, since the performance has been sluggish for around a month and I cannot blame any new installations for this. The PCI lock seems the only way to temporarily solve the problem.

       

      Any help would be greatly appreciated!

        • 1. Re: i7-4712HQ does not reach 100% of the clock speed when "PCI Lock" is Unchecked in Advanced Boot settings
          EstebanC_Intel

          Hello Kastytis_D:

           

          Thank you for contacting the Intel® Communities.

           

          OEM devices may have special settings that could limit the speed of the processor, this could be applied to get a good and reliable performance from your device, this power management feature disabled indeed affects the system, PCI interface would handle different connections that would be affected as in this case.

           

          I would like you to test the system with the Intel® Processor Diagnostic Tool to check the processor status.

           

          Also, have you tried contacting the manufacturer (Dell) of the device to get support on this product?

          Download Intel® Processor Diagnostic Tool (64-bit)

          Download Intel® Processor Diagnostic Tool (32-bit)

           

          Regards,

          Esteban C

          • 2. Re: i7-4712HQ does not reach 100% of the clock speed when "PCI Lock" is Unchecked in Advanced Boot settings
            Kastytis_D

            Hi Esteban C,


            Thank you for your response. I am yet to get in touch with the manufacturer (bad past experience dealing with the Tech Support, wanted to leave it as last option).


            I understand that the OEM power management is in place in order to provide stable performance, but in this case, the throttling has a significant effect on the usability of the device (clock speeds significantly under the designed parameters). As a result, the system is running slowly, and producing little heat (fan rarely kicks in, even when Task Manager states that the CPU is at 100% usage for extended periods of time (like the CPU stress test), as you can see at the results below (Temperature = 46 degrees C below maximum.) It feels like there's something holding it back, which can be disabled by turning the PCI Lock on.


            Hope the culprit is hiding here somewhere!


            Here are the results of diagnostics (Pass):


             

            ---------------------------

            --- Testing Processor 1 ---

            ---------------------------

             

             

            --- IPDT64 - rev  2.20.0.0.W.MP ---

             

             

            --- Start Time: 12/30/2015 21:40:49---

             

             

            --- Skipping Config ---

             

             

            --- Reading CPU Manufacturer ---

             

             

            Expected --> GenuineIntel

            Detected --> GenuineIntel

            Found --- Genuine Intel Processor ---

             

             

            --- Temperature Test ---

             

            Temperature Test Passed!!!

             

             

            Temperature = 46 degrees C below maximum.

             

             

            --- Reading Brand String ---

             

             

            Detected Brand String:

            Intel Core i7-4712HQ   2.30GHz

             

             

            Brand String Test Passed!!!

             

             

            --- Reading CPU Frequency ---

             

             

            Expected CPU Frequency is --> 2.30

             

             

            Detected CPU Frequency is --> 2.26166

             

             

            CPU Frequency Test Passed!!!

             

             

            --- FSB NOT Supported on this Processor ---

             

             

            --- Running Base Clock test ---

             

             

            Detected Base Clock --> 102

            Base Clock test Pass ---

            ..QPI rate Test not supported..

            ..Skipping QPI rate Test..

             

             

            Skipping QPI rate Test

             

             

            --- Running Floating Point test ---

             

             

            Million Floating Points per Second, MFLOPS --> 288

            Floating Point Test Pass ---

             

             

            --- Running Prime Number Generation Test ---

             

             

            Operation Per Second--> 4.65205e+006

            Prime Number Generation Test Pass ---

             

             

            --- Reading Cache Size --- 

             

             

            - Detected L1 Data Cache Size --> 4 x 32

            - Detected L1 Inst Cache Size --> 4 x 32

             

             

            - Detected L2 Cache Size --> 1024

            - Detected L3 Cache Size --> 6144

             

             

            Cache Size Test Passed!!!

             

             

            --- Determining MMX - SSE capabilities ---

             

             

              --- CPU FEATURES DETECTION FOR ---

                         ---        MMX SSE       ---

            MMX - MMX Supported --> Yes

            SSE - SSE Supported --> Yes

            SSE2 - SSE2 Supported --> Yes

            SSE3 - SSE3 Supported --> Yes

            SSSE3 - SSSE3 Supported --> Yes

            SSE4.1 - SSE4.1 Supported --> Yes

            SSE4.2 - SSE4.2 Supported --> Yes

              --- MMX SSE - capabilities check complete ---

             

             

            MMX Test Result --- PASS

            SSE Test Result --- PASS

            SSE2 Test Result --- PASS

            SSE3 Test Result --- PASS

            SSSE3 Test Result --- PASS

            SSE4.1 Test Result --- PASS

            SSE4.2 Test Result --- PASS

            MMX SSE Testing Passed !!

             

             

            --- Determining AVX AES PCLMULQDQ capabilities ---

             

             

              --- CPU FEATURES DETECTION FOR ---

                        --- AVX/AES/PCLMULQDQ ---

            AVX - Advanced Vector Extensions Supported --> Yes

            AVX OS Support   - AVX Operating System Supported --> Yes

            AES - Advanced Encryption Standard Supported --> Yes

            PCLMULQDQ - Polys Carry-Less Multiply Supported --> Yes

              --- AVX AES PCLMULQDQ capabilities check complete ---

             

             

            AVX Compare Test Result --- PASS

            AES Test Result --- PASS

            PCLMULQDQ Test Result --- PASS

            AVX AES PCLMULQDQ Testing Passed !!

             

             

            --- Reading Memory Size ---

             

             

            Detected Memory Size is --> 16.00GB

             

             

            --- Integrated Memory Controller Stress Test ---

             

             

            --- Integrated Memory Controller Stress Test Pass!!! ---

             

             

            Integrated Memory Controller Test Pass!!!

             

             

            Chipset          : HM87 SKU

             

             

            1 device connected to PCI Express Port 0

               1 : NVIDIA Quadro K1100M

             

             

            No device connected to PCI Express Port 1

             

             

            1 device connected to PCI Express Port 3

               1 : Intel(R) Dual Band Wireless-AC 7260

             

             

            1 device connected to PCI Express Port 4

               1 : Realtek PCIE CardReader

             

             

            No device connected to PCI Express Port 5

             

             

            2 device connected to SATA Controller 1

               1 : HGST HTS541010A7E630

               2 : SAMSUNG SSD SM841N mSATA 512GB

             

             

            4USB devices detected

               1 : Intel(R) Wireless Bluetooth(R)

               2 : USB Composite Device

               3 : Microsoft Mouse and Keyboard Detection Driver (USB)

               4 : USB Input Device

             

             

            1 device connected to Intel High Definition Audio Controller

               1 : Realtek High Definition Audio

             

             

            --- Platform Controller Hub Test Completed!!! ---

             

             

             

            --- Querying for Intel(R) Integrated Graphics Device (IGD) ---

             

             

            ..Detected 8086 as Vendor ID on Device 2 on Intel(R) processor..

            ..Intel(R) Integrated Graphics Device Presence Detection Passed..

             

             

            ..2D Graphics Visual Display Passed..

             

             

            ..Graphics Visual Display Passed..

             

             

            ..Rotating Display Passed..

             

             

            --- CPU Load ---

             

             

            --- Load Level = 8

             

             

            CPU Load Passed!!!

             

             

            --- Temperature Test ---

             

             

            Temperature Test Passed!!!

             

             

            Temperature = 34 degrees C below maximum.

             

             

            --- Test End Time: 12/30/2015 21:44:49---

             

             

             

            System Information

            ------------------

            Processor Name: Intel(R) Core(TM) i7-4712HQ CPU @ 2.30GHz

            Processor Information: Intel64 Family 6 Model 60 Stepping 3

            Number of Physical Cores: 4

            Number of Logical Cores: 8

            Installed System Memory: 16 GB

            Operating System: Microsoft Windows 10 Pro 64-bit

            Graphics Information: NVIDIA Quadro K1100M

            System Product: DELL PRECISION M3800

            System BIOS: A10

            PASS



            • 3. Re: i7-4712HQ does not reach 100% of the clock speed when "PCI Lock" is Unchecked in Advanced Boot settings
              EstebanC_Intel

              Hello Kastytis_D:

               

              There may be something bad with the processor or just a limitation from the OEM to get the best performance out of the device.

               

              Please do provide us with the resolution provided by OEM support for future customer that could encounter with this situation.

               

              Regards,

              Esteban C

              • 4. Re: i7-4712HQ does not reach 100% of the clock speed when "PCI Lock" is Unchecked in Advanced Boot settings
                Kastytis_D

                If anyone has this particular problem, I have discovered whats causing it (not how to resolve it though).

                 

                After some more playing around, I got desperate and "reset" the OS (keeping my files). Which, to my surprise, didn't help. I did some windows system checks in cmd (sfc and dism) and the tools found some corrupt files (which they were unable to repair due to the source files being corrupt also). I then provided dism a fresh windows iso to take the system files from, and the image got successfully repaired. This, unfortunately did not solve my problem.

                 

                Here is the corrupt system file that could not be repaired:

                Could not reproject corrupted file [l:23 ml:24]"\??\C:\WINDOWS\SysWOW64"\[l:10]"opencl.dll"; source file in store is also corrupted

                 

                I then proceeded to do a complete factory reset (since I lost all of my applications anyway, there was nothing else for me to lose). The system rolled back to W8.1, which is really strange, since I have deleted all previous windows.old files through Disk Cleanup. Even though I got downgraded, good news. The throttling was gone, and the disk spun down when directed. I was prompted to upgrade to W10, which I did (the download and installation process is rather time consuming..) and once up and running, the processor still functions correctly.

                 

                My next step, naturally was to update all of my drivers using my product key on DELL's website.

                I downloaded them all manually, and kept checking my processor after each install/restart. Everything worked fine until I installed the:

                *Intel Dynamic Platform and Thermal Framework Driver*

                After a reboot, the task manager once again showed up the dreaded 2.28GHz. I set a system restore point just as the WIndows was fully booted up, before updating the drivers, so I decided to restore it to that point. No luck, the processor still being Throttled. Since I've nothing to lose, once again, I do a complete reinstall (which once again, rolls be back to W8.1. After around an hour, W10 up and running. I proceeded to update all of my drivers, excluding the Dynamic Platform and Thermal framework driver, with reasonable success. The processor is no longer throttled. The only issue, after installing the Motion Sensor Driver, the HDD stopped spinning down. At this point, I dont have time to play around anymore, so decided not to roll back.

                 

                So, at the end of the day, the culprit to my problems were the official DELL drivers:

                 

                System Utilities |Intel Dynamic Platform and Thermal Framework Driver (104MB)

                &

                ST Microelectronics LNG3DMTR Motion Sensor Driver (35 MB)


                With the fresh installation of Windows (and the Motion Sensor Driver Installed), once again SFC/scannow found errors that could not be repaired. Through DISM, I managed to repair the system image, but the HDD still spins freely. Most importantly, the Throttling is GONE.

                 

                I have no idea why would the official Dell drivers corrupt the system file, since they were after all, designed for this particular system, on this particular OS. There were no other programs to interfere with their installation and operation, since the drivers were the first things to be updated. It seems that the drivers cause some substantial damage, if not even system restore can change it.

                 

                 

                Either way, in my case, it was the DELL's drivers. Hope this helps anyone with the same issue!

                • 5. Re: i7-4712HQ does not reach 100% of the clock speed when "PCI Lock" is Unchecked in Advanced Boot settings
                  EstebanC_Intel

                  Hello, Kastytis_D:

                   

                  I am glad to hear that you were able to encounter with the source of this particular issue.

                   

                  It will certainly be helpful for other users of Intel® Communities.

                   

                  Also, have you contacted the manufacturer of your device to address this issue?

                   

                  If you encounter with any new or additional inquiries, do not hesitate to contact the Intel® Communities again.

                   

                  Regards,

                  Esteban C