8 Replies Latest reply on Jan 9, 2016 3:19 AM by myopenid

    How to install batman-adv module

    myopenid

      I'm trying to install batman-adv mesh networking module. This is what I tried.

       

      1. Download opkg package from repo.

      2. Install said .ipk file with opkg (at this point, opkg did not give any error but batman-adv module still doesn't show up on lsmod, so proceeded to install manually)

      3. Copy batman-adv.ko from

      /lib/modules/3.10.17-yocto-standard/kernel/net/batman-adv/ to /lib/modules/$(uname -r)

      4. Run modprobe -f batman-adv

      Got "modprobe: ERROR: could not insert 'batman_adv': Exec format error"

       

      modinfo of batman-adv.ko is

      filename:  /lib/modules/3.10.17-poky-edison+/batman-adv.ko
      version:   2013.2.0
      description:B.A.T.M.A.N. advanced
      author:    Marek Lindner <lindner_marek@yahoo.de>, Simon Wunderlich <siwu@h

      rz.tu-chemnitz.de>

      license:   GPL
      srcversion:66711903985B5CAAE0DAF30

      depends:

      intree:    Y
      vermagic:  3.10.17-yocto-standard SMP preempt mod_unload ATOM

       

      /proc/version/ is Linux version 3.10.17-poky-edison+ (sys_dswci@tlsndgbuild004) (gcc version 4.9.1 (GCC) ) #1 SMP PREEMPT Fri Jun 19 12:06:40 CEST 2015

       

      How do I proceed?